Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

One more about SSL and HTTPS


gnarly parts

Recommended Posts

Dave,

I think there is a problem with your cert and/or installation on the server. Trying just https://www.gnarlyparts.com doesn't show a padlock for me. On some pages the server switches back to http for me at least. https://www.gnarlyparts.com/account.php ==> http://www.gnarlyparts.com/login.php

I'm setting up an install right now and the link to My Account from index.php shows a https link. Your is showing a http link. I would double check both your catalog/includes/configure.php and catalog/admin/includes/configure.php (or where you have it).

Your SSL cert should implement on your home page, so for sure check that first.

Link to comment
Share on other sites

If you SSL your entire site you will never get any search spiders on your site. If that doesn't matter then go for it.

I thought (I don't know) that search spiders will search for http. When you 'link/redirect' to https, then the padlock appears. Or is that all wrong :unsure:

Link to comment
Share on other sites

Dave,

I think there is a problem with your cert and/or installation on the server. Trying just https://www.gnarlyparts.com doesn't show a padlock for me. On some pages the server switches back to http for me at least. https://www.gnarlyparts.com/account.php ==> http://www.gnarlyparts.com/login.php

I'm setting up an install right now and the link to My Account from index.php shows a https link. Your is showing a http link. I would double check both your catalog/includes/configure.php and catalog/admin/includes/configure.php (or where you have it).

Your SSL cert should implement on your home page, so for sure check that first.

Hi. I know my site is doing that now.. I have turned off the SSL for now until I figure out what is wrong. My site is live so I can't have those pop up errors.

 

Thanks for taking a look.

 

Dave

Always looking for a way to improve my sites.

Link to comment
Share on other sites

Hi again...did you happen to bind an IP address to the other certificate as well? I'm pretty sure it needs it own.

Hi, Yes I have difference IPs for every site with a cert. I got my guy very close to finding the problem. It's in the cert. Something about them "cert" needing more information to authorize the cert. "turn on"

 

Thanks for the help

 

Dave

Always looking for a way to improve my sites.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...