Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Basic Template Structure does not work


shuva

Recommended Posts

hello

 

this ist my firts posting here. I tried to install BST on a localhost and followed the readme but i always get this error:

 

"Fatal error: Failed opening required 'templates/TEMPLATENAME_MAIN_PAGE' (include_path='') in c:\apache\htdocs\shop\catalog\index.php on line 150"

 

I modified configure.php:

define('DIR_WS_TEMPLATES', 'templates/');

define('DIR_WS_CONTENT', DIR_WS_TEMPLATES . 'content/');

define('DIR_WS_JAVASCRIPT', DIR_WS_INCLUDES . 'javascript/');

 

Checked all the files 50 times and can?t find what i did wrong.

 

greetings

shuva

Link to comment
Share on other sites

OK I confess... I installed the BTS and got the same error.... very interesting.

Hmm..... I wonder if Tim will have an anwser for us...

<span style='font-family:Courier'>If you can't fix it Perl it!!!...</span>

******************************

Link to comment
Share on other sites

I figured my problem out...

 

I was using the default setup that my web host had setup, and either it was an older version or they just didn't install everything.

 

So I downloaded the latest milestone version, uploaded it to my server & installed it, added the BTS mods and everything is working now.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...