Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

ssl again stumped


clearnet

Recommended Posts

Hi

I have been using osC for a while and thought I would ssl my connection.

after an upgrade etctetc.

 

these are my config files. (below) (latest download of osC)

 

1. I get a message saying you are entering a secure area but no padlock etc.

ssl is working though please advise.

2. I ssl'd my admin all was ok but some images were wrongly linked and missing ? (less important)

 

 

admin

 

// Define the webserver and path parameters

// * DIR_FS_* = Filesystem directories (local/physical)

// * DIR_WS_* = Webserver directories (virtual/URL)

define('HTTP_SERVER', 'http://www.jewellerygalleria.com'); // eg, http://localhost - should not be empty for productive servers

define('HTTP_CATALOG_SERVER', 'http://www.jewellerygalleria.com');

define('HTTPS_CATALOG_SERVER', 'https://sslrelay.com/jewellerygalleria.com');

define('ENABLE_SSL_CATALOG', 'true'); // secure webserver for catalog module

define('DIR_FS_DOCUMENT_ROOT', '/homepages/16/d71503419/htdocs/jewellerygalleria/catalog/'); // where the pages are located on the server

define('DIR_WS_ADMIN', '/catalog/admin/'); // absolute path required

define('DIR_FS_ADMIN', '/homepages/16/d71503419/htdocs/jewellerygalleria/catalog/admin/'); // absolute pate required

define('DIR_WS_CATALOG', '/catalog/'); // absolute path required

define('DIR_FS_CATALOG', '/homepages/16/d71503419/htdocs/jewellerygalleria/catalog/'); // absolute path required

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');

define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');

define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');

define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');

define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');

 

catalog

 

define('HTTP_SERVER', 'http://www.jewellerygalleria.com'); // eg, http://localhost - should not be empty for productive servers

define('HTTPS_SERVER', 'https://sslrelay.com'); // eg, https://localhost - should not be empty for productive servers

define('ENABLE_SSL', true); // secure webserver for checkout procedure?

define('HTTP_COOKIE_DOMAIN', 'www.jewellerygalleria.com');

define('HTTPS_COOKIE_DOMAIN', 'sslrelay.com/jewellerygalleria.com');

define('HTTP_COOKIE_PATH', '/catalog/');

define('HTTPS_COOKIE_PATH', '/catalog/');

define('DIR_WS_HTTP_CATALOG', '/catalog/');

define('DIR_WS_HTTPS_CATALOG', '/jewellerygalleria.com/catalog/');

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 

define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');

define('DIR_FS_CATALOG', '/homepages/16/d71503419/htdocs/jewellerygalleria/catalog/');

define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');

define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

 

many thanks I have been reading the forum under ssl for 4 hours with no clues

david

 

you can check the ssl on https://sslrelay.com/jewellerygalleria.com/...des/spiders.txt (in ie)

Link to comment
Share on other sites

thanks for the reply

it was just something I tried to force ssl compliance.

 

I have changed back to the original config they both work but no ssl. padlock.???

you can use the store directly at /catalog/ without the frame .

 

 

 

the frame was only there as I was hoping to run affiliat_branding etc for more than 1 shop, but with the new oscaffiliate I am looking for another solution ??

 

but hey no padlock yet

but thanks for the reply

 

cheers dc

 

UPDATE : I HAVE MANAGED TO RUN THE WHOLE SITE SECURED.

for any body that is having a similar proble I believe the padlock does not show because the images arrive unsecured, setting the http_server to your Https setting runs the whole thing secure. seema to be a fudge but works .... for secure pathways, ie a shared secure route to your original folders.

dc

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...