Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

warning on oscommerce configuration(NW Install)


Chin-Chin

Recommended Posts

At the end of the installation process of oscommerce y receive this warnings :

 

Warning: fopen(/webserver/s001/domain.com/catalog/includes/configure.php) [function.fopen]: failed to create stream: Permission denied in \\webserver\s001\domain.com\catalog\install\templates\pages\install_7.php on line 209

 

Warning: fputs(): supplied argument is not a valid stream resource in \\webserver\s001\domain.com\catalog\install\templates\pages\install_7.php on line 210

 

Warning: fclose(): supplied argument is not a valid stream resource in \\webserver\s001\domain.com\catalog\install\templates\pages\install_7.php on line 211

 

Warning: fopen(/webserver/s001/domain.com/catalog/admin/includes/configure.php) [function.fopen]: failed to create stream: Permission denied in \\webserver\s001\domain.com\catalog\install\templates\pages\install_7.php on line 259

 

Warning: fputs(): supplied argument is not a valid stream resource in \\webserver\s001\domain.com\catalog\install\templates\pages\install_7.php on line 260

 

Warning: fclose(): supplied argument is not a valid stream resource in \\webserver\s001\domain.com\catalog\install\templates\pages\install_7.php on line 261

The configuration was successful!

 

Then I go to the administration tool an i receive this :

 

Warning: Can't connect to MySQL server on 'localhost' (10061) in \\webserver\s001\domain.com\catalog\admin\includes\functions\database.php on line 19

 

Warning: MySQL Connection Failed: Can't connect to MySQL server on 'localhost' (10061) in \\webserver\s001\domain.com\catalog\admin\includes\functions\database.php on line 19

Unable to connect to database server!

 

Anyone who knows why ???

Link to comment
Share on other sites

Hello Chin-

 

Please forgive the ignorance in my post if you have already done this. :rolleyes:

But, have you made sure that permissions have been correctly set for all files, directories and users of those files and directories?

I was pulling my hair out about httpd authentication in Apache until I figured that one out! ;)

 

I hope this helped.

 

Peace,

Sixosix

"Everything was fine until dickless here turned off the power."

"Is this true?"

"Yes. It's true. This man has no dick."

-Ghostbusters

Link to comment
Share on other sites

Don?t worry Sixosix...

Honestly, I hire a Hosting with all items necessary for oscommerce, but I don?t have access to the real folders, only from my domain root and folders.

 

So, I am literally fighting with this hosting service provider, they are making tests, but I think that if someone here just tell me only what to do and then talk about with my HSP...

 

Hope someone knows how.....

now i am pulling my hair out !!!!

 

Thnx

 

Chin

Link to comment
Share on other sites

I am using ipowerweb, and dont know if my fix just relates to their site or to OS. anyway I just changed the permission of \catalog\install\templates\pages\install_7.php to 706. I am not sure if I need to change it back after installation, but I will probably change he chmod back to 644 or something after install..

 

Tell me if you get it fixed and what you do afterwards.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...