Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

RMA Returns error for 2.2 MS2


Guest
 Share

Recommended Posts

I'll give it a shot and mark the places where I did my editing. And if I miss something, I'm online all day working so I'll be tracking this thread for problems. I'm not a php expert and can't write code, it was all just trial and error fixing.

 

I'll ftp my files over and work on them today.

Link to comment
Share on other sites

I'll give it a shot and mark the places where I did my editing. And if I miss something, I'm online all day working so I'll be tracking this thread for problems. I'm not a php expert and can't write code, it was all just trial and error fixing.

 

I'll ftp my files over and work on them today.

Hi Cathy,

 

Thanks... your work is much appreciated. I'll look forward to it. :D

Link to comment
Share on other sites

Ok guys....I remembered the best I could. What I did was FTP the files back into the original RMA Returns System that will have all the cleanup that I did to make it work on my sites. Have included extra documentation in the ReadMe files.

 

http://www.oscommerce.com/community/contributions,1136

 

I'll help out the best I can if errors pop up, because I might have missed something which then I can add it to the ReadMe file.

Link to comment
Share on other sites

In addition, I didn't do any changes to the Gift Voucher files, since I don't use gift vouchers. So, if errors pop up from that area, I can't help.

 

Send Password from the Customers Admin side has been corrected, along with other minor problems that were causing errors.

Link to comment
Share on other sites

hello all,

 

i did install this contribution as well, but i have just one minor problem:

the customer does not see the status which is selected, and when i select the "complete this return" box and hit "update" there still is a rma number displayed at the customer side.

 

any way to fix this? what if a produkt is damaged 2 times?

(or did i just miss something :rolleyes: )

 

thanks for your help

Edited by zlack

It's easier to remember, then to forget

Link to comment
Share on other sites

how can you damage a product two times? if it has been purchased once and returned once?

 

to send back to the customer, you are better off to generate another order, referencing the original along with the rma # given the customer.

 

the customer will always have access to the # on their order history and rma area history.

Link to comment
Share on other sites

Hi I have just installed this contribution and dont know where to start to get it to work. Basicially when i try to log a product for return it has a box asking for product name with an x next to it and what ever i type in it end up with an erro saying quantity doesnt match order. Sounds like something ins not being called somewhere in the code. ANy Suggestions??

Link to comment
Share on other sites

Namer: I just did a test order thru my store and I see what you are talking about. When the customer clicks Return under the product it takes them to the Return a Product screen.

 

The box should show initially the total number ordered for that product, then the X then the Product Title. () represents box:

 

eg: (5) x cf2002-23 CRYSTAL DOLPHIN WITH BALL $92.75

 

I want to return 3 of those so I change the number shown to 3. Fill out the rest of the info and I get an RMA after clicking on Request.

 

Double check and make sure you did all the additional changes from the ReadMe file or the doc folder file that was there previously.

Link to comment
Share on other sites

Thanks for your response. Maybe i am doing something wrong heer or have jumped ahead a few steps.

Basically what i have done is made a link in the information box taking straight to the return product form. just as there is the return tracking link as in the instructions. Am i doing the wrong thing here, like do you have to access teh return product form through account history or something like this..

 

 

Thankyou so much in advance for helping me wioth this..

 

 

Cheers!!! :)

Link to comment
Share on other sites

Ahhhh...yes. The Returns is in the customers account history. Therefore, they have to login and go to their account information. When they "view" an order placed that is where you will see the "Return" under each product ordered.

 

I have put instructions in my return policy (not like customers read those anyway!) on how to return a product. For the Quick Checkout folks, they have to go another route since they don't have access to their history. (Hint) I create a fake order using their address (to get correct shipping amount) and before I close my browser I found I can click on My Account and view the order history, return the product they want to return, generate an RMA, then I close my browser to end that session.

 

HTH!

 

(What I'm going to do to make sure it all works again, and I didn't miss any of the steps I did to fix things, I have another site that I built for someone and add this contribution there. Will let you all know if it works first shot!)

Edited by only2empires
Link to comment
Share on other sites

Hi Cathy,

 

I installed this contrib and found the followings:

 

1. In Admin, under the customer return I can't insert a new refund method such as 'Credit card VISA' and I got a blank screen on the monitor when I pressed the insert button. I can edit the existing refund method such 'PayPal' to 'Wire Transfer'.

 

The above happens to 'Return Reasons' & 'Return Status' as well. Did I do something wrong?

 

 

2. I tried to return a product and found that when I pressed a request button in the return a product page, I was being diverted to a log-in page and I have to log-in again. Did I missed something? Is there anyway to solve this problem?

 

Thanks. :D

Link to comment
Share on other sites

Hmmm...Mine doesn't do that, the hitting request and it takes me back to login page. I just did another install on this other guys site and all went smoothly, no errors, no problems. Maybe its colliding with another contribution you have going. I'll look in the codes and see what actually controls that and maybe we can find it in case others have problems. But like I said, mine directs me right to the RMA number.

 

I too found if you want to add anything new like refund reasons, methods...etc. I had to go to phpMyAdmin to do it. Don't know whats up with that, and I don't know how to fix that since I'm not a php expert to figure that part out.

 

We WILL get through this!!! HAHAHA

 

One more thing: if any of you are like me and do a Find to find text in the php file, under catalog/includes/classes/order.php I had in the ReadME

 

'final_price' => $orders_products['final_price'],);

 

should be:

 

'final_price' => $orders_products['final_price']);

 

and that is replaced with:

 

'final_price' => $orders_products['final_price'],

'id' => $orders_products['products_id'],

'return' => $orders_products['products_returned'],

'exchange' => $orders_products['products_exchanged'],

'exchange_id' => $orders_products['products_exchanged_id'],);

 

Sorry :blink:

Edited by only2empires
Link to comment
Share on other sites

Here's a thought. In this includes/account_history_info.php try changing the NONSSL to SSL if you are on a secured server.

 

Open catalog/account_history_info.php

Find====>

 

for ($i=0, $n=sizeof($order->products); $i<$n; $i++) {

 

 

Add====>

 

if ($order->products[$i]['return'] == '1') {

$rma_query_one = tep_db_query("SELECT returns_id FROM " . TABLE_RETURNS_PRODUCTS_DATA . " where products_id = '" . $order->products[$i]['id'] . "' and order_id = '" . $HTTP_GET_VARS['order_id'] . "'");

$rma_query = tep_db_fetch_array($rma_query_one);

$rma_number_query = tep_db_query("SELECT rma_value FROM " . TABLE_RETURNS . " where returns_id = '" . $rma_query['returns_id'] . "'");

$rma_result = tep_db_fetch_array($rma_number_query);

 

$return_link = '<font color=cc0000><b>' . TEXT_RMA . ' # <a href="' . tep_href_link('returns_track.php', 'action=returns_show&rma=' . $rma_result['rma_value'], 'NONSSL') . '">' . $rma_result['rma_value'] . '</a>';

} else {

$return_link = '<a href="' . tep_href_link(FILENAME_RETURN, 'order_id=' . $HTTP_GET_VARS['order_id'] . '&products_id=' . ($order->products[$i]['id']), 'NONSSL') . '"><font color=cc0000><b>' . TEXT_RETURN_PRODUCT .'</a></b></font>';

}

 

 

Not sure if that might have anything to do with it...but give it a shot!

Link to comment
Share on other sites

Hi Cathy,

 

It just came into my mind. What if some customers who abuse the return request??

 

This is due to the fact that all the products in the order history can be returned...

What if the customer who used the product two months later and log-in request for product refund? May I suggest that before RMA number is given, the program should be able to detect the time difference, say may be within 30 days, so that RMA number can be released or else no RMA number be released. :rolleyes:

Link to comment
Share on other sites

HAHA I have no clue about writing stuff like that. Maybe some guru expert can figure that one out. What you are saying is after your time limit for the return, the Return link under the product disappears or when they request an RMA it pops up a message, return time expired or something like that.

 

Even without that you must stick with YOUR return policy. If you receive a return request 2 months later and your policy says you have 30 days, I would add in your return policy a statement like:

 

If an RMA is requested after the time frames stated for a return of a product(s), we have the right to decline your return request. Should we decided to accept your return request a restocking fee of $XX will apply. All decisions made by us regarding your late return are final.

 

Sounds rough, but I have been burnt and don't plan on taking any more losses! It is up to the customer to read all your policies before placing the order. All you can do is provide them the information, but we all know you can lead a horse to water but you can't make him drink!

Link to comment
Share on other sites

Hi

 

Two major problems encountered.

 

1. When I pressed the request button to return the product at the return_product page, I was being diverted to the log-in page. I had to log-in again in order to see the RMA number. I tried the solution posted by Joe on Mar 26 2004 and it did not work!!!

 

2. At the Track the return product page, when I entered the RMA number and clicked the button, I was diverted to the log-in page again. It just repeatedly showing the log-in page when I clicked the button.

 

Form the thread, others experience the same problems before. Anyone care to share your experience? :rolleyes: :rolleyes:

Link to comment
Share on other sites

Well gosh! I'm not sure what's going on. I did 4 installs and everything went smoothly.

 

Now on the Track A Return, when I put in the tracking number, if I'm not signed in it will divert me to the login...but once I login it takes me directly to the Return A Product page to show the status.

 

What I did with the already existing php files was do a copy/paste the changed parts of the files instead of an Upload file and replace the entire file since I have modified my site so much. All the new files I just did a direct upload. Then I did the changes on the ReadMe.

 

The existing php files in the folder are:

 

admin/includes/languages/english.php

catalog/includes/boxes/information.php

catalog/includes/functions/general.php

catalog/includes/languages/english/account_history_info.php

 

What other contributions are you using?

Link to comment
Share on other sites

Hi Cathy,

 

Well I tried to install this contrib on the osC 2.2 MS2 without any contrib and the problems exist. I did exactly in the readme file and copy all the files into new osC 2.2 MS2. May be I installed this under Win Xp, Apache 2, PHP & MySQl. Usually this is how I tested the contrib before implementation.

 

Any clues. :ph34r:

Link to comment
Share on other sites

I have no clue...sorry. I am using osC 2.2 MS2 also. I upload all my contributions directly from my cpanel and just save the file as a different name before I change it, just in case I have to change things back. All I can say is it works fine on the 4 sites I put it on with no problems. The one site I added it to had a few contributions, but nothing that would affect this contribution and still works.

 

Maybe a guru can check into it more or knows more about what could be causing it.

 

I'm stumped :blink:

Link to comment
Share on other sites

the contribution works, just have to follow the instructions completely.

 

i used a file comparison utility which works, to make sure that everything is being merged properly and at the right points.

 

one thing i have not done yet is set up the rma to block requests if the order is older than 30 days.

 

i have set in the customer returns area that the initial is only an Return Authorization Request, it is not anything they can use at this time to reutrn products. They MUST' use the label sent to them in email when customer service authorizes the return.

Link to comment
Share on other sites

How du i change the returns_text.php file in this line to store the text vith the corsponding language id ????

 

if ($REQUEST_METHOD=="POST")

{

mysql_query('REPLACE INTO return_text VALUES (1, 1, "' . $aboutus .'")')

or die(mysql_error());

}

 

$sql=mysql_query('SELECT * FROM return_text where return_text_id = 1')

or die(mysql_error());

$row=mysql_fetch_array($sql);

 

this is the (1, 1, where the last 1 have to be the language_id.

 

not 1 bout as 4 for english and 5 for Danish ???????

Jorn

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...