Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Common OSCommerce Problem


oscmember

Recommended Posts

Hi,

 

I have done some searches in the forums regarding this problem but I was unable to find a clear solution. I am trying to configure OSCommerce to:

 

1) Connect to the DB in my PC. I have placed the phpmyadmin and OSCommerce directories in the www directory on my machine. OSComemrce keeps returning an error message indicating that localhost is not a correct hostname. I have tried changing the config files in both catalog/admin and catalog/includes, but with no luck.

 

2) In another directory on my PC I am trying to import the DB from my online server. When trying to do this OSCommerce setup wizard indicates dbxxx.host.com does not exist. I run another site from the same db hostname and it works.

 

Can anyone please help?

 

DH

Link to comment
Share on other sites

1) Connect to the DB in my PC. I have placed the phpmyadmin and OSCommerce directories in the www directory on my machine. OSComemrce keeps returning an error message indicating that localhost is not a correct hostname. I have tried changing the config files in both catalog/admin and catalog/includes, but with no luck.

Does phpMyAdmin work?

Have you setup a proper users for that database for that domain.

 

ie:

 

osc_database@localhost

AND

[email protected]

 

with the proper pemissions?

 

2) In another directory on my PC I am trying to import the DB from my online server. When trying to do this OSCommerce setup wizard indicates dbxxx.host.com does not exist. I run another site from the same db hostname and it works.

 

Unless the DNS of dbxxx.host.com is pointing to your local machine then your configure.php or simular config file of your application is not correct. Try 'localhost' not 'http://dbxxx.host.com'

 

OR are you downloading the RAW SQL files???? Can NOT do that (UNLESS YOU HAVE AN IDENTICAL SETUP). Try doing an SQL Dump and then load that file into a new SQL database on your PC.

Link to comment
Share on other sites

Hi,

 

thanks for the replies. I think I am making a mistake because I am not setting up properly a user id and password for the DB on my localhost/127.0.0.1. I am using phpmyadmin, which works fine on my machine. I have put the phpmyadmin dir in the www dir of my virtual server (I am using EasyPHP1.6).

 

I have imported my online DB manually to the DB on my machine, and I have created a second DB (I have two DBs available online, one is used by one site, the other will be used by this new site I am trying to build with OSCommerce). How do I change the access details of each DB on my machine?

 

Thanks for your help,

 

DH

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...