Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

email settings


q582gmzhi

Recommended Posts

Hi,

 

Just installed the oscommerce package alls working well at the moment, but I am having problems with the email.

 

I can't remember inputting my mail server details into the set-up and now its coming up with error messages when completing a test customer account.

 

On packages like this, I normally have to input details about email settings like:

 

mailserver = "mail.fsmith.co.uk"

 

But I cant recall inputting this kind of info for osCommerce.

 

Where do I input the mailserver address??

 

Thanks

 

Darrell...

Link to comment
Share on other sites

Hi,

 

Found this posting regarding looking in server info:

 

http://www.oscommerce.com/forums/index.php?showtopic=57244

 

However when I click server info in configuration I get hit with:

 

CGI Error

The specified CGI application misbehaved by not returning a complete set of HTTP headers.

 

Is their CGI in oscommerce?? if so what files\folders do I need to tag up in my server setting for CGI scripting.

 

Thanks

 

Darrell...

Link to comment
Share on other sites

Your host is probably running PHP as CGI and has the phpinfo command disabled. If you are using Linux, osCommerce uses the Linux mail command to send mail. If your host runs MS Windows, at the top of includes/classes/email.php, try

ini_set('SMTP', 'mail.whatever.com');
ini_set('sendmail_from', '[email protected]')

Hth,

Matt

Link to comment
Share on other sites

Hi,

 

Thanks for the feedback but I am unable to get that to work.

 

Keep getting the following error:

 

PHP Warning: mail() [function.mail]: Failed to connect to mailserver at "" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in D:\webppliance\conf\domains\w0557969905\Inetpub\wwwroot\catalog\admin\includes\classes\email.php on line 500 PHP Warning: Cannot modify header information - headers already sent in D:\webppliance\conf\domains\w0557969905\Inetpub\wwwroot\catalog\admin\includes\functions\general.php on line 18

 

Being new to PHP I have tried putting the command both above and below the <?PHP command line as shown:

 

ini_set('SMTP', 'mail.mydomain.co.uk');

ini_set('sendmail_from', '[email protected]')

<?php

 

or

 

<?php

ini_set('SMTP', 'mail.mydomain.co.uk');

ini_set('sendmail_from', '[email protected]')

 

Thanks

 

Darrell...

Link to comment
Share on other sites

Just to confirm, you tried making the second change (which is correct, after <?php) in admin/includes/classes/email.php (as opposed to catalog/includes/classes/email.php; if you get it working in one, eventually you would want to change *both* places).

 

If it still isn't working, perhaps your host has disabled ini_set?

 

Hth,

Matt

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...