Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

AuthorizeNet checkout


meimei

Recommended Posts

I am currently using snapshot-20030917 and using Authorize Net as my payment method.

 

When I made a test order and ready to checkout, the script calls transaction.dll as normal process. Then it asks me to login or creat an account, though I am already login. If I login again, it takes me to login page for the third time login. The interesting part is I still receive merchant receipt and confirmation, which means the transaction did make it through. What am I doing wrong? I set the receipt URL to http://myshopurl/checkout_success.php at the AuthorizeNet end, but it doesn't seem to work. Help~~~~

Link to comment
Share on other sites

I look through almost entire forum, found some message say set the response/receipt url to checkout_process.php . So I went to AuthorizeNet control panel to do so, but it still takes me to login page instead of checkout_success.php

 

Help~~~~

Link to comment
Share on other sites

Try it with admin > Configuration > Sessions > Force Cookie Use set to true and see if that helps. It sounds like it's losing the session when it switches to Authorize.net.

 

Hth,

Matt

Link to comment
Share on other sites

I am having the same issue. Authorize.net redirects to the login page instead of the checkout_success page. What exactly did you change in the admin to get it to work? Here's my setting in sessions:

 

Session Directory -> /tmp

Force Cookie Use -> True

Check SSL Session ID -> True

Check User Agent -> True

Check IP Address -> False

Prevent Spider Sessions -> False

Recreate Session -> True

 

 

 

Did you set everything to true? Did you hand code some changes?

 

Thankyou in advance.

Link to comment
Share on other sites

  • 4 weeks later...
  • 1 month later...

Any solutions? I am also having this problem:

 

"During the checkout process, it redirects to https://secure.authorize.net/gateway/transact.dll

and this is when it asks me to login again. At the same time, I receive the email merchant receipt and order confirmation."

 

Up until now I have been keying in orders through Authorize.net's terminal. I am setting up a new shopping cart and wanted it to be automatic.

 

I have tried changing the settings mentioned above. What settings are necessary in Authorize.net?

 

Thanks,

Clay

Link to comment
Share on other sites

Any solutions? I am also having this problem:

 

"During the checkout process, it redirects to https://secure.authorize.net/gateway/transact.dll

and this is when it asks me to login again. At the same time, I receive the email merchant receipt and order confirmation."

 

Up until now I have been keying in orders through Authorize.net's terminal. I am setting up a new shopping cart and wanted it to be automatic.

 

I have tried changing the settings mentioned above. What settings are necessary in Authorize.net?

 

Thanks,

Clay

Link to comment
Share on other sites

  • 1 month later...
  • 2 years later...

I'm having the same issue too. I verified my settings as suggested by a previous user, but that didn't help.

 

I submit an order, it takes me to: https://secure.authorize.net/gateway/transact.dll. That then redirects me to the login page as if the order didn't happen. Finally, I get an email letting me know the order went through. The customer should get a receipt, not be directed to the login page.

 

What can I do?

 

Thanks,

 

Chris Miller

Link to comment
Share on other sites

  • 5 months later...
  • 6 months later...
  • 2 weeks later...

I have resolved my issue so I hope this helps all of you:

 

Go to Admin > Configuration > Sessions

 

Set all settings to false. Once I did this, authorize.net started to properly go to the correct check out page instead of showing the login screen.

 

Session Directory /tmp

Force Cookie Use False

Check SSL Session ID False

Check User Agent False

Check IP Address False

Prevent Spider Sessions False

Recreate Session False

Link to comment
Share on other sites

  • 3 weeks later...

The problem is that if you want search engine friendly URLs to be enabled, then you need to make sure that session is stored in a cookie. Therefor you need to have force cookie use turned on to true.

 

I've tracked the problem down to the following code in application_top.php

 

  if (SESSION_FORCE_COOKIE_USE == 'True') {
 	error_log("forced to use cookies for session");
   tep_setcookie('cookie_test', 'please_accept_for_session', time()+60*60*24*30, $cookie_path, $cookie_domain);

   if (isset($HTTP_COOKIE_VARS['cookie_test'])) {
    error_log("test cookie was set, lets start the session");
     tep_session_start();
     $session_started = true;
   } else {
    error_log("test cookie FAILED");
}
 }

 

The problem is that temporary cookie is not being set after the return from authorize.net.

 

Any thoughts as to the best way to correct this?

 

-B

Link to comment
Share on other sites

  • 4 weeks later...

I'm still having the same problem with Authorize.net. I have an SSL Certificate installed as well.

 

I went to Admin > Configuration > Sessions and set all the settings like Adam recommended above:

 

Session Directory /tmp

Force Cookie Use False

Check SSL Session ID False

Check User Agent False

Check IP Address False

Prevent Spider Sessions False

Recreate Session False

 

When I I submit an order (in the checkout_confirmation.php page), it takes me to: https://secure.authorize.net/gateway/transact.dll; then redirects me to the checkout_payment.php page (one step back) and asks for the CC# again, and from here is gets into a loop that never ends.

 

Can anyone please help?

Thank you,

Dany :huh:

Link to comment
Share on other sites

  • 1 month later...

I went to Admin > Configuration > Sessions and set all the settings recommended above:

 

Session Directory /tmp

Force Cookie Use False

Check SSL Session ID False

Check User Agent False

Check IP Address False

Prevent Spider Sessions False

Recreate Session False

 

This WORKED for ME!!! Thanks so much!! :)

 

**NOTE: I played around with the Settings and set "Check IP Address" to "True". When I did this it stopped working for me.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...