Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

About to go live, then I get this error


kittidid

Recommended Posts

When I go to my homepage I get this error. I have looked all around the forum to find an answer and nothing!

 

I get this error:

 

Warning: Failed opening 'includes/languages/english/FILENAME_DEFINE_MAINPAGE' for inclusion (include_path='') in /usr162/home/wgroom/public_html/shop/catalog/index.php on line 307

 

Help please!

 

Kitti

Link to comment
Share on other sites

Anytime you see FILENAME_SOMETHING_IN_ALL_CAPS, it is a sign that your filenames.php (in MS2, used to be in application_top.php) is not getting included properly or is missing the relevant define. I would expect FILENAME_DEFINE_MAINPAGE to be from a layout contribution, like Center Shop, you may want to go back through the instructions of the contributions that you have installed to find which one provides that.

 

Hth,

Matt

Link to comment
Share on other sites

I looked up the same line in the original index.php page and the

exact same words and marks apply. I also restored the original application top and filenames php pages. Nothing worked. I am still getting the same error. There are words in caps on every page in OSC, so I don't understand that caps info you gave.

 

Still need help please!

 

Kitti

Link to comment
Share on other sites

I have seen this before - it is a contribution, but I don't remember what :blink:

 

Add this to your filenames.php - this is just a guess as to what the filename actually is - perhaps it would be better for you to look in your languages directory:

 

define('FILENAME_DEFINE_MAINPAGE', define_mainpage.php');

 

HTH

 

Matti

Link to comment
Share on other sites

Hi Johnson,

 

Good to have your help. You have helped me before and I had great success. I added that line you requested. I did look in that folder before to be sure that the line was located in it and it was on my PC but not on the server. However,

 

Now, I am getting this error:

 

Fatal error: Cannot redeclare tep_db_connect() (previously declared in /usr162/home/wgroom/public_html/shop/catalog/includes/functions/database.php:13) in /usr162/home/wgroom/public_html/shop/catalog/includes/functions/database.php on line 13

 

I have got to get live, please help.

 

Kitti

Link to comment
Share on other sites

  • 1 month later...

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...