Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

how do I make password for my admin page?


imjinoh

Recommended Posts

Hi, I looked for a lot of answers here and no one actually tells you how to make

 

.htaccess file to protect your admin folder.

 

and I'm having a trouble with my admin folder just showing up without asking me a password and ID.

 

Can anyone please tell me one by one how to make ID and password for my admin folder?

 

Thank you.

Link to comment
Share on other sites

If your hosting company offers CPanel (or similar) you can do it thruw directory protection.

If not check the contributions section (click my signature) and search for admin protection

 

The_Bear

Link to comment
Share on other sites

I am posting this information as it worked for me to password protect a directory on my E-Smith Server.

-------------------------------------------------------------------------------------

 

Password files:

1. Create the directory you want to password protect (example: private)

 

2.Create a file /home/e-smith/files/ibays/ibaysname/html/private/.htaccess in that directory that looks something like this using pico:

 

AuthName "Add your login message here."

AuthType Basic

AuthUserFile /home/e-smith/files/ibays/ibaysname/html/private/.htpasswd

AuthGroupFile /dev/null

<Limit GET POST>

require user name-of-user

</Limit>

 

*Note: In this case the "name-of-user" is the login name you wish to use for accessing the web site.

 

3.Create the password file /home/e-smith/files/ibays/ibaysname/html/private/.htpasswd using the program htpasswd:

 

htpasswd -c .htpasswd name-of-user

 

Apache configuration file:

 

Here is where the httpd.conf file is located on YES server: /etc/httpd/conf/httpd.conf

 

Default: This disables the processing of .htaccess files for the system.

 

<Directory />

AllowOverride None

</Directory>

 

or for a specified directory:

 

<Directory /home/e-smith/files/ibays/ibaysname/html>

AllowOverride None

</Directory>

 

Change to and/or specify directory to protect:

 

<Directory /home/e-smith/files/ibays/ibaysname/html/private>

AllowOverride All

</Directory>

 

OR

<Directory /home/e-smith/files/ibays/ibaysname/html/private>

AllowOverride AuthConfig

</Directory>

 

AllowOverride parameters: AuthConfig FileInfo Indexes Limits Options

 

I used this in my httpd.conf:

<Directory /home/e-smith/files/ibays/ibaysname/html/private>

AllowOverride All

</Directory>

 

And then there was Success!!!!!

Link to comment
Share on other sites

It crashed my server...............

 

 

The last time I tried to do this, I tried a contrib, that needless to say, also crashed my server.

 

 

Hmmmmmmmmmmmmmmmmmmm will try and try again.......

 

 

Jeremy R. Viccari

Sr LAN WAN Engineer

www.elitelan.com

oscommerce cvs 2.2 on YES 1.5.2 linux

www.elitelan.com/elcstore/catalog

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...