Jump to content
  • Checkout
  • Login
  • Get in touch


The e-commerce.

Easy Populate Bugs


Recommended Posts

I've hit a wall with Easy Populate. I'm trying to convert our current store over to osCommerce, and with over 6,000 products, it's a little out of the question to do it by hand!


Anyway, the problem is that when inserting new products Easy Populate will often ignore my top-level categories and throw the second or third level categories into the root without any rhyme or reason. Some products it handles just fine, and other ones seem to get a random category that may actually be the product's price, or another product's "active/disabled" field. Everything appears to be setup correctly. Anyone have ideas as to why it may be doing this?

Link to comment
Share on other sites

If you have a single quote in your product description, you may try using a backslash before the quote like \' so as it ignores the actual meaning of quote in php file and takes it as a character.


Hope this helps!

Link to comment
Share on other sites

Jeez, I can't get this to work for the life of me. Removing all the quotes only made matters worse. I told my boss that converting to osCommerce would be a snap, but I just can't get Easy Populate to cooperate.


If you want to take a look at my spreadsheet, it's located at http://dev.golfcarcatalog.com/catalog/temp/db.txt. Can anyone please help me with this? It's driving me nuts! My catalog is all set up in the standard directories on a test server, so feel free to take a look at my configurations.

Link to comment
Share on other sites

Still no dice. I've tried deleting every single quote and double-quote, putting slashes in front of them, stripping all the HTML, replacing the tabs with various characters, editting the PHP script to strip out all whitespace, and every combination of each. Do you have any other ideas, because I'm all out. :(

Link to comment
Share on other sites



Hrm, it may have something to do with the XHTML in the product descriptions. Perhaps the quotes...? Does anyone have ideas on how to get around this?

Easy Populate is not equipped to handle xhtml. You can enter everything except the product descriptions. Also make sure every line ends with EOREOR

[no external urls in signatures please, kthanks]

Link to comment
Share on other sites

I banged my head agains the wall a bit today with this. Not 6000 items.. BUT 252. It was skewing the colums and was doing weird things.

This even AFTER reading and making settings changes as per te documentation.


But, I finally got it to work. It seems it keys completely off the V_PRODUCTS_MODEL information. If there is nothign there, wham skewing.

If you put in 1 "model" number, wham only 1 item gets inserted/updated.


Make sure you have UNIQUE v_products_model information in there for each item!! Once you do this... it "should" work.


Great little add on.... wish that there was a "NOTE: be careful about...." in the documentaion!

But a great add on nonetheless






Edited by nitchimon




Motto for today:

I went to school to become a wit. But I only made it half way.

Link to comment
Share on other sites

  • 4 weeks later...

Well, I have posted and posted and modified the documentation and practically screamed into cyberspace that each product needs a UNIQUE MODEL NUMBER. I can't help it if no oe pays attention :)

[no external urls in signatures please, kthanks]

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...