Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Problem with SSL for Admin Area


Guest

Recommended Posts

I am having a problem securing my admin section with SSL. When I enter the admin section all the URLs are showing http:// rather than https://

 

This is causing an error since I have added SSLRequireSSL to the admin/.htaccess file.

 

I have set the following in the admin/includes/config.php file

 

  define('HTTP_CATALOG_SERVER', 'https://www.mydomain.com');
 define('HTTPS_CATALOG_SERVER', 'https://www.mydomain.com');
 define('ENABLE_SSL_CATALOG', 'true'); // secure webserver for catalog module

 

but this still doesn't work.

 

The admin area works fine without using SSL

 

Does anyone have ideas?

 

Thanks

 

Rob

Link to comment
Share on other sites

Look in the catalog/includes/local folder. See if you have configure.php file in there. If you do open that and see if the http and the https is set. What I learned is if the configure.php file is located in that folder it overides the configure.php file in the catalog/includes folder.

Link to comment
Share on other sites

:unsure: Hi All,

 

I'm having similar problems with my secure server. After a customer logs in, the secure index.php automatically comes up...meaning that if I have added new products via the admin, their pictures don't show. How do I avoid having to upload pictures in two places? Do I need to have the products catalog on the secure server too? Help?!

 

// Define the webserver and path parameters
// * DIR_FS_* = Filesystem directories (local/physical)
// * DIR_WS_* = Webserver directories (virtual/URL)
 define('HTTP_SERVER', 'http://www.mysite.com.au'); // eg, http://localhost - should not be empty for productive servers
 define('HTTPS_SERVER', 'https://secure.mysite.com.au'); // eg, https://localhost - should not be empty for productive servers
 define('ENABLE_SSL', 'true'); // secure webserver for checkout procedure?
 define('HTTP_COOKIE_DOMAIN', 'www.mysite.com.au');
 define('HTTPS_COOKIE_DOMAIN', 'secure.mysite.com.au');
 define('HTTP_COOKIE_PATH', '/catalog/');
 define('HTTPS_COOKIE_PATH', '/catalog/');
 define('DIR_WS_HTTP_CATALOG', '/catalog/');
 define('DIR_WS_HTTPS_CATALOG', '/catalog/');
 define('DIR_WS_IMAGES', 'images/');
 define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
 define('DIR_WS_INCLUDES', 'includes/');
 define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
 define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
 define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
 define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
 define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

Link to comment
Share on other sites

I have just checked and there is no configure.php files under catalog/includes/local or admin/includes/local.

 

I'm using OSC 2.2 MS2

 

I though adding the following to the .htaccess file might do as a workaround but the page just seems to lock up when tryng to access any of the admin pages through a browser

Redirect /admin https://www.mysite.com/admin

 

Can anyone help?

 

Cheers

 

Rob

Link to comment
Share on other sites

Adding the trailing slash doesn't work either. I think this is setting up a circular redirect.

 

Trying to solve the original problem of forming the https:// URLS rather than the http:// URLS I have tried to looking at the PHP code. I am very new to this but I have noticed that definition of the tep_href_link function is different between the admin area and the catalogue area, could this be related?

 

On my setup I have moved the admin area out of the catalogue area so I have

 

www.mydomain.com/admin

www.mydomain.com/catalogue

 

Thanks for the suggestions so far

 

Rob

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...