Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Continue shopping button now working...


jwsfun

Recommended Posts

I'm having a problem with my "continue shopping" button...If I add a product to the shopping cart and click on the "continue shopping" button, I'm directed BACK to the product I just entered, and not to the main default page. Does anyone know how and where to fix this? Please help...Thanks! :D

Link to comment
Share on other sites

This is actually a little more detailed: If I navigate to a category and then click on the "buy now" button and go to the shopping cart page and THEN click on the "continue shopping", I'm directed BACK to the category I jus tcame from (which is fine and what I want to happen). BUT, as I mentioned the first time, if I go into a ctaegory, click on an item and go to the page that displays the item image and description, and THEN click on the "continue shopping" button, I'm directed BACK to the item I just put into the shopping cart and NOT back to the category page. Is this a problem with the checkout_process.php or something else?

Link to comment
Share on other sites

I think you have to change the navigatin history -2 to -3.

 

Watch it, the minus occurs more than once in the snapshot i use, so you have to change it on i tink 3 places.

Where do I go to make this change to see if it will work?

Link to comment
Share on other sites

Thanks for the tip...I opened shopping_cart.php and changed the "-2" on line 120 to a "-3" and it works now. It's the only place I saw that "-2" setting (I'm using the 2.2 CVS OSC), but it's all working now. Thanks again! :D

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...