Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

setting and resetting permissions


moisea

Recommended Posts

hello forum,

does anyone PLEASE know how to :

Reset the permissions on /catalog/includes/configure.php to 644, 
Set the permissions on /catalog/images directory to 777 
Reset the permissions on /admin/includes/configure.php to 644 
Create the dir /admin/backups and set the permissions to 777 
Set the permissions on /admin/images/graphs directory to 777

 

i dont know how to use chmod. an example will be very helpful. i use localhost.

I REALLY NEED HELP PLEASE!!!!!!!

Link to comment
Share on other sites

If you can log on to a command prompt, you could (on Linux/Unix--MS is different) do:

 

chmod 644 catalog/includes/configure.php

chmod 777 catalog/images

cd catalog

chmod 644 admin/includes/configure.php

mkdir /admin/backups; chmod 777 /admin/backups

chmod 777 admin/images/graphs

 

This assumes the default MS2 install and that you are in the root directory with catalog as one of the listings. However, most people do this with their FTP client (WS_FTP or whatever). Generally, you right click on the file or directory, select properties, and set to the following:

 

777: owner, group, and other check read, write, and execute for each

644: owner gets read and write, group and other get only read (uncheck write if it's checked; execute doesn't really matter)

 

If this doesn't work for you, more connection details would be helpful. Are you using a control panel like CPanel or HSphere? Are you connect with an FTP program? Do you have shell access (make sure that you are in the right directory and run the commands above)?

 

Hth,

Matt

Link to comment
Share on other sites

  • 3 months later...

I am having the same problem. I am using Cpanel and cannot seem to change the permissions at all.

 

Any Help on this would be great.

Link to comment
Share on other sites

I am having the same problem. I am using Cpanel and cannot seem to change the permissions at all.

 

Any Help on this would be great.

If your site is on a virtual private server, as most of our sites are, then you may not have the right permissions to chmod files. Check with your hosting provider. Also, if you are on a Windows server you won't be able to use FTP to chmod files (this may confuse you because it may appear that you have successfully chmod'd them when in fact you haven't). Do you have SSH access? If so you can navigate to the directories concerned and chmod them directly e.g. chmod 644 configure.php (remember to return it to 400 alter editing). Hope this helps. Vger

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...