Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Won't Send mail to domains


Guest

Recommended Posts

I'm having problems when users create a account...

 

it doesn't send mail to emails:

yahoo.com, hotmail.com,aol.com, and certain webmail services...

 

so I think I need to set it up for SMTP, and not phpmail...

but unlike invision board theres no way to specify any values

 

all there is, is selecting either smtp or phpmail

 

is there a way to configure this beyond these two settings?

 

if so How exactly...what file do I need to edit...

 

need answer quickly please help...

Link to comment
Share on other sites

could you explain this better please...what do you mean...

how is this possible...?

 

Yes I use that register for my domains..

 

we also use exim mail server...

 

I need this fixed...bigtime...

 

osCommerce is one of the scripts offered in our CPanel

Link to comment
Share on other sites

I have my test user and store email yahoo.com addresses. I have send mail setup. I did not set this up. My ISP did - maybe yours can do this for you?

 

Have you tried going into Configuration->Email options->Email Transport method and selecting sendmail or is yours a Windows/Macos server?

 

MG

Link to comment
Share on other sites

It is possible to block mail from certain domains/domain blocks using a SPAM filter - check with your host - if you are sending mail ok to certain domains, but not others, then this is the most likely cause - other osCommerce users do send mail ok to them from their domains.

Link to comment
Share on other sites

Do you have E-Mail From in your Admin panel set to an address from your store? That is, if your store is mystore.com, this address needs to be [email protected]. Some spam filters compare the From line to the real sender and reject mail that does not match.

See my profile for a list of my addons and ways to get support.

Link to comment
Share on other sites

  • 2 weeks later...

Hi,

 

I had a simalar problem with my mailserver 'argosoft'.

 

The problem was in my mail server settings I had the IP address as the local host.

 

I had to change it to "mail.joebloggs.co.uk" or whatever your server mail account is setup as. This cured the problem for me.

 

Dont know if this is what you are suffering from.

 

Darrell.....

Link to comment
Share on other sites

Also, another way SPAM filters come into play is that they check for DNS configuration. For email to work properly, the email address from which you send needs:

 

1. An MX record for the domain (the part after the @). This will look something like mail.yourdomain.com.

 

2. An A record for the MX record. This would say that mail.yourdomain.com has IP (for example) 192.168.1.100.

 

3. A PTR record for the A record. This would say that 192.168.1.100 is the IP for mail.yourdomain.com (essentially a backwards A record).

 

If Johnson's guess is correct and you're server is being blocked as a SPAMmer (or open relay/proxy) directly with an IP ban or such, then you will have to use a different mail server. To do this, you would need to install the SMTP w/ Authentication contribution and configure it to use an outside mail server.

 

Hth,

Matt

 

P.S. Another thing to check is to send email to yourself and look at the header: from whom is it sent? STORE_OWNER_EMAIL_ADDRESS? Or something else? If it is some kind of server default, HotMail, etc. may not like something about it.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...