Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

great problem


khan2002

Recommended Posts

hello everybody!

 

i've a great problem: after filling in all userdatas and klick on next step a blank side follows.

 

the history of my page:

 

first i installed oscommerce on my webspace in a catalog directory!

i configured oscommerce and all worked well.

now i changed my domainname to go direct to the catalog file!

after editing the both configure phps all works fine,but after creating an account i get a blank page - no success screen. the e-mails are sent and in mysql the datas are available.

 

now i've tried every way that i can image to solve this, but i find no way.

 

please please help me

Link to comment
Share on other sites

Well, at the moment all I'm getting is this:

 

Warning: main() [function.main]: open_basedir restriction in effect. File(/usr/share/php/includes/application_top.php) is not within the allowed path(s): (/home/www/web419/) in /home/www/web419/html/index.php on line 13

 

Warning: main(includes/application_top.php) [function.main]: failed to create stream: Operation not permitted in /home/www/web419/html/index.php on line 13

 

Fatal error: main() [function.main]: Failed opening required 'includes/application_top.php' (include_path='.:/usr/share/php') in /home/www/web419/html/index.php on line 13

Link to comment
Share on other sites

I recieved this:

Warning: reset() [function.reset]: Passed variable is not an array or object in /home/www/web419/html/includes/classes/email.php on line 71

 

Warning: Variable passed to each() is not an array or object in /home/www/web419/html/includes/classes/email.php on line 72

 

Fatal error: Call to a member function on a non-object in /home/www/web419/html/includes/functions/general.php on line 970

 

Which are all email related. Check your settings in admin.

Link to comment
Share on other sites

now i disabled sending e-mails and i get the following comment:

 

Error!

 

Unable to determine the page link!

 

Query was empty - Query was empty

 

Query was empty

 

[TEP STOP]

 

 

Warning: Unknown(): A session is active. You cannot change the session module's ini settings at this time. in Unknown on line 0

Link to comment
Share on other sites

Now I can actually see the site (which I couldn't before) but you have this warning at the top.

 

Warnung: Das Installationverzeichnis ist noch vorhanden auf: /home/www/web419/html/install. Bitte l?schen Sie das Verzeichnis aus Gr?nden der Sicherheit!

Warnung: osC kann in die Konfigurationsdatei schreiben: /home/www/web419/html/includes/configure.php. Das stellt ein m?gliches Sicherheitsrisiko dar - bitte korrigieren Sie die Benutzerberechtigungen zu dieser Datei!

 

 

This means you need to change permissions on the configure.php file to 644.

 

I will try and create a test account and get back to you on the other problem.

Link to comment
Share on other sites

OK, the problem seems to be that the continue button at the bottom of the page is set to go to create_account.php insrtead of create_account_process.php

 

I created an account in my own site to see what it did and it briefly flicked to create_account_process.php before being diverted to create_account_success.php. Yours just went back to create_account.php, so it wasn't being told to go to create_account_success.php, which comes at the end of the create_account_process.php file.

 

Look at about line 46 of create_account.php for this code:

 

<!-- body_text //-->

 

Underneath, it should say:

 

   <td width="100%" valign="top"><?php echo tep_draw_form('account_edit', tep_href_link(FILENAME_CREATE_ACCOUNT_PROCESS, '', 'SSL'), 'post', 'onSubmit="return check_form();"') . tep_draw_hidden_field('action', 'process'); ?>

 

Now I am not great at code, but as that is the only reference to create_account_process.php in the entire file, I would say that that is the bit which tells it to go to create_account_process.php. Yours might say FILENAME_CREATE_ACCOUNT instead.

 

HTH

Link to comment
Share on other sites

Sorry to post three times - not spamming - had another thought.

 

If that doesn't work, look in application_top.php and make sure you have this line

 define('FILENAME_CREATE_ACCOUNT_PROCESS', 'create_account_process.php');

and that it is correct.

Link to comment
Share on other sites

  • 2 months later...

I do not have this in any application*.php file at all, and I cannot create an account. When I click on continue the location bar says:

 

http://xxx.xxx.xxx.xxx/wholesale/FILENAME_...ACCOUNT_PROCESS

 

and then I get a 404 error.

 

can anyone give me a hand with this. If I cannot create an account the proggy is useless to me :(

 

>define('FILENAME_CREATE_ACCOUNT_PROCESS', 'create_account_process.php');

 

Thank you

aspeciality AT hotmail DOT com

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...