Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Admin directory doesn't ask for password


ICECold2

Recommended Posts

If your Hosting provider supplies CPanel password protect your admin folder with "directories protection"

If not check the contributions section (click on my signature) there is a few that does just that

And for the writing permission chmod your files at 644

 

The_Bear

Link to comment
Share on other sites

  • 2 weeks later...

Hey guys, I am posting this information as it worked for me to password protect a directory on my E-Smith Server.

-------------------------------------------------------------------------------------

 

Password files:

1. Create the directory you want to password protect (example: private)

 

2.Create a file /home/e-smith/files/ibays/ibaysname/html/private/.htaccess in that directory that looks something like this using pico:

 

AuthName "Add your login message here."

AuthType Basic

AuthUserFile /home/e-smith/files/ibays/ibaysname/html/private/.htpasswd

AuthGroupFile /dev/null

<Limit GET POST>

require user name-of-user

</Limit>

 

*Note: In this case the "name-of-user" is the login name you wish to use for accessing the web site.

 

3.Create the password file /home/e-smith/files/ibays/ibaysname/html/private/.htpasswd using the program htpasswd:

 

htpasswd -c .htpasswd name-of-user

 

Apache configuration file:

 

Here is where the httpd.conf file is located on YES server: /etc/httpd/conf/httpd.conf

 

Default: This disables the processing of .htaccess files for the system.

 

<Directory />

AllowOverride None

</Directory>

 

or for a specified directory:

 

<Directory /home/e-smith/files/ibays/ibaysname/html>

AllowOverride None

</Directory>

 

Change to and/or specify directory to protect:

 

<Directory /home/e-smith/files/ibays/ibaysname/html/private>

AllowOverride All

</Directory>

 

OR

<Directory /home/e-smith/files/ibays/ibaysname/html/private>

AllowOverride AuthConfig

</Directory>

 

AllowOverride parameters: AuthConfig FileInfo Indexes Limits Options

 

I used this in my httpd.conf:

<Directory /home/e-smith/files/ibays/ibaysname/html/private>

AllowOverride All

</Directory>

 

And then there was Success!!!!!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...