Jump to content
  • Checkout
  • Login
  • Get in touch


The e-commerce.

Simple Easypopulate problem


Recommended Posts

Hello everyone, I'm running into a simple problem with Easy Populate 2.62 that I can't seem to figure out.


Everything works fine when I create the txt file, and even when I upload the EP file. However, after I finish uploading my EP file, the products_date_available field gets todays date (which I want to leave blank) and products_date_added is left blank even though it has values in the EP file.


Anyone have a similar problem?


Your help is greatly appreciated, thanks!

Link to comment
Share on other sites

  • 3 months later...

I am having the exact same problem. I just spent about 4 hours on this for nothing.


The problem seems to stem from export.

My date format in mysql is YYYY-MM-DD HH:MM:SS but when I export it turns into DD/MM/YYYY HH:MM:SS AM/PM


If I manually reset it with the excel by changing the field then I can upload and it will work ok. So we seem to just have a serious export problem within easy populate. Is there some function for the date time? I have combed through the code and I just cant seem to figure it out. I have tried almost everything.


I am running MS1 from a June Snapshot.



There seems to be 2 thread started both with the same problem. How about a fix on this?


I have narrowed it down to the cause now we just need the answer. Whatever the solution is it should be added to the manual of EP.

Link to comment
Share on other sites

OK..something really odd.


Look at the file when you download it in a plain text editor.


The dates are fine. I think we are all having Excel problems. Seems like excel might be reformatting the export for some reason, which is a problem but I can use openoffice too.


Very odd thing and what a waste of time. DIE MS DIE!

Link to comment
Share on other sites

Actually I have the same problem even when I just download the model nubmer/qty/price option and then I upload it again without even opening the file...

So excel is not even touching the file and there is no date field in the file.

Link to comment
Share on other sites

On excel you need to change the format of the date field into text. This is done through format>cells, then text.


Although (to the best of my knowledge) you do not need to have that column in your file, because if it isn't there then EP won't know to change ay of these values.


Let me know how you get on.



Link to comment
Share on other sites

thats good to know that I can just delete the column..


when I use this I just need to change prices and quantity in stock


so can I just have model number, name, quantity, and price in the EP and upload it...I just want to make sure

this would make things really easy

Link to comment
Share on other sites

  • 4 months later...

Just in case anyone is still interested....


Easypopulate expects the date format to be 0000-00-00 00:00:00 i.e. YYY-MM-DD HH:MM:SS and if not in that format it will bugger the data upon import. If you do not enter the date in excel in this format you will thus bugger the catalog database. Even if you enter the date in the expected format but excel changes it to any other format you will bugger the data upon import. Do not expect that just by saving it as a text file it will convert it back; it won't. Once excel sees a date it converts it to a numerical code and represents it as a date in whatever format you have the cell formated to. When you save as text it mearly saves it as you have formatted the cell. If you want success then the column for the date must be formatted as text in excel so that excel does not convert your entry into excel date format but instead leaves it in the expected format from the get go. If when you enter the date in the expected format it stays as entered you will have success. ;)


If you examine your files from excel after saved as text in word or some other text editor you will see what excel is giving you and you are giving easypopulate. Go ahead and look at what you were importing into easypopulate before and you will see that it is not in the expected format and look at what you are importing now to insure it is.

I have moved on from oscommerce to magento and no longer monitoring this site.

Link to comment
Share on other sites

  • 2 months later...

I think i found the solution:


The default way dates and times are displayed by Excel (and in the system generally) can be changed at the Windows level, if you have the privileges (you don't have them on the public PCs). In Windows 98 onwards, you can also amend the default settings for 2-digit year interpretation (from 1930-2029). If you want to alter these settings you need to go to the Control Panel files. DO NOT CARRY OUT THE FOLLOWING INSTRUCTIONS UNLESS YOU NEED TO:


From the Window's Start button choose Settings then Control Panel

Double click on the Regional Options (or, in Windows 98, Regional Settings) icon

On the Date tab you can set up a format for both short and long date styles and you can change the date separator (e.g. from a slash to a hyphen). In Windows 2000 onwards you also have a When a two-digit year is entered, interpret as a year between: box

On the Time tab you can set up the Time format: and you can change the Time separator: (from a colon

Link to comment
Share on other sites

  • 4 months later...

when I download a full ep file to edit, open it in excel, get rid of the dates columns, description, attributes then upload only the data I want to I still get todays date!?? WTF

Link to comment
Share on other sites

http://www.oscommerce.com/forums/index.php?showtopic=64945 is the support thread for easypopulate, you can find just about every answer in there.

if you read thru your code (easypopulate.php) you fill find out why deleting the columns doesnt work. documentation states that too.


anyway, long story short, post questions/answers in the support thread. that is what they are for. not just for ep but all contributions have their own support thread.

Link to comment
Share on other sites

Hi all


I'm having a problem with EP 2.74 Nov29 contrib.


When I click on "Download complete tab-delimited .txt file to edit" it downloads fine, but does not have the other pricing groups (I have 3 - wholesale, friend, cost)


If I click on "Download Model/Price/Qty tab-delimited .txt file to edit" it downloads all the pricing no problem at all.


I performed the mod suggested in the instructions, and uncommented the first 3 customer pricing groups as follows:

  // uncomment the customer_price and customer_group to support multi-price per product contrib
 $filelayout = array(
	 'v_products_model'  => $iii++,
	 'v_products_price'  => $iii++,
	 'v_products_quantity'  => $iii++,
	 'v_customer_price_1'  => $iii++,
	 'v_customer_group_id_1'  => $iii++,
	 'v_customer_price_2'  => $iii++,
	 'v_customer_group_id_2'  => $iii++,
	 'v_customer_price_3'  => $iii++,
	 'v_customer_group_id_3'  => $iii++,
	 #'v_customer_price_4'  => $iii++,
	 #'v_customer_group_id_4'  => $iii++,


The beginning of my easypopulate.php file is as follows:


// Current EP Version
$curver = '2.72-MS2-Max';

 $Id: easypopulate.php,v 2.72 2003/11/27 VJ Exp $

// C O N F I G U R A T I O N
// V A R I A B L E S

// **** Temp directory ****
// if you changed your directory structure from stock and do not have /catalog/temp/, then you'll need to change this accordingly.
$tempdir = "/temp/";
$tempdir2 = "/temp/";

//**** File Splitting Configuration ****
// we attempt to set the timeout limit longer for this script to avoid having to split the files
// NOTE:  If your server is running in safe mode, this setting cannot override the timeout set in php.ini
// uncomment this if you are not on a safe mode server and you are getting timeouts
set_time_limit(330); // VJ changed

// if you are splitting files, this will set the maximum number of records to put in each file.
// if you set your php.ini to a long time, you can make this number bigger
global $maxrecs;
$maxrecs = 300; // default, seems to work for most people.  Reduce if you hit timeouts
//$maxrecs = 4; // for testing

//**** Image Defaulting ****
global $default_images, $default_image_manufacturer, $default_image_product, $default_image_category;

// set them to your own default "We don't have any picture" gif
//$default_image_manufacturer = 'no_image_manufacturer.gif';
//$default_image_product = 'no_image_product.gif';
//$default_image_category = 'no_image_category.gif';

// or let them get set to nothing
$default_image_manufacturer = '';
$default_image_product = '';
$default_image_category = '';

//**** Status Field Setting ****
// Set the v_status field to "Inactive" if you want the status=0 in the system
// Set the v_status field to "Delete" if you want to remove the item from the system <- THIS IS NOT WORKING YET!
// If zero_qty_inactive is true, then items with zero qty will automatically be inactive in the store.
global $active, $inactive, $zero_qty_inactive, $deleteit;
$active = 'Active';
$inactive = 'Inactive';
//$deleteit = 'Delete'; // not functional yet
$zero_qty_inactive = false;

//**** Size of products_model in products table ****
// set this to the size of your model number field in the db.  We check to make sure all models are no longer than this value.
// this prevents the database from getting fubared.  Just making this number bigger won't help your database!  They must match!
global $modelsize;
$modelsize = 25;

//**** Price includes tax? ****
// Set the v_price_with_tax to
// 0 if you want the price without the tax included
// 1 if you want the price to be defined for import & export including tax.
global $price_with_tax;
$price_with_tax =false;

// **** Quote -> Escape character conversion ****
// If you have extensive html in your descriptions and it's getting mangled on upload, turn this off
// set to 1 = replace quotes with escape characters
// set to 0 = no quote replacement
global $replace_quotes;
$replace_quotes = false;

// **** Field Separator ****
// change this if you can't use the default of tabs
// Tab is the default, comma and semicolon are commonly supported by various progs
// Remember, if your descriptions contain this character, you will confuse EP!
global $separator;
$separator = "\t"; // tab is default
//$separator = ","; // comma
//$separator = ";"; // semi-colon
//$separator = "~"; // tilde
//$separator = "-"; // dash
//$separator = "*"; // splat

// **** Max Category Levels ****
// change this if you need more or fewer categories
global $max_categories;
$max_categories = 3; // 7 is default

// VJ product attributes begin
// **** Product Attributes ****
// change this if you want to download selected product options
// this might be handy, if you have a lot of product options, and your output file exceeds 256 columns (which is the max. limit MS Excel is able to handle)
global $attribute_options_select;
$attribute_options_select = array('', ''); // uncomment and fill with product options name you wish to download // comment this line, if you wish to download all product options
// VJ product attributes end


Any suggestions appreciated. The quicker I fix this, the quicker I can use my Access front end for entering stock :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...