Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

localhost/shop/admin/index.php works, but...


Phillius22

Recommended Posts

Hellooo :shock:

 

when I try to load up my index file (http://localhost/shop/index.php) :

 

1046 - No Database Selected

 

select configuration_key as cfgKey, configuration_value as cfgValue from configuration

 

[TEP STOP]

 

however, localhost/shop/admin/index.php works, but localhost/shop/index.php doesn't......why is that? anyone know?

I'm using windows 2000, using iis. for some reason i can't even look at localhost/shop.....but can look at localhost/shop/admin/ don't get it!?? :?

 

cheers in advance.

Link to comment
Share on other sites

have tried searching for related topics and there are people who have the "1046 - No Database Selected" problem, but they don't have the same problem as I do. My main problem is the main index doesn't work but the admin/index does. I've checked the two configure.php files and it should work!!

Link to comment
Share on other sites

have tried searching for related topics and there are people who have the "1046 - No Database Selected" problem, but they don't have the same problem as I do. My main problem is the main index doesn't work but the admin/index does. I've checked the two configure.php files and it should work!!

 

You can try install it again for your own self.. it?s easy and use to work...

first you have to oppen the oscommerce.sql archive on your notepade, than you can open your mysql front or the myadmin and put the contents of the oscommerce on it in this step you?re building your database and you have to save it. To conclude you may open the configure.php in the includes folder and in the admin/includes and configure that things ( http, https, username, database...)

 

It worked with me....

Link to comment
Share on other sites

You can try install it again for your own self.. it?s easy and use to work...  

first you have to oppen the oscommerce.sql archive on your notepade, than you can open your mysql front or the myadmin and put the contents of the oscommerce on it in this step you?re building your database and you have to save it. To conclude you may open the configure.php in the includes folder and in the admin/includes and configure that things ( http, https, username, database...)

 

huh?? Ok i opened the oscommerce.sql in wordpad....what do you mean put the contents of oscommerce on it?

 

sorry....oscommerce beginner i am :roll:

Link to comment
Share on other sites

here's my catalog configure.php:

 

// Define the webserver and path parameters

// * DIR_FS_* = Filesystem directories (local/physical)

// * DIR_WS_* = Webserver directories (virtual/URL)

 define('HTTP_SERVER', 'http://localhost/'); // eg, http://localhost - should not be empty for productive servers

 define('HTTPS_SERVER', 'https://localhost/'); // eg, https://localhost - should not be empty for productive servers

 define('ENABLE_SSL', true); // secure webserver for checkout procedure?

 define('HTTP_COOKIE_DOMAIN', 'http://localhost/');

 define('HTTPS_COOKIE_DOMAIN', 'http://localhost/');

 define('HTTP_COOKIE_PATH', '/shop/');

 define('HTTPS_COOKIE_PATH', '/shop/');

 define('DIR_WS_HTTP_CATALOG', '/shop/');

 define('DIR_WS_HTTPS_CATALOG', '/shop/');

 define('DIR_WS_IMAGES', 'images/');

 define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

 define('DIR_WS_INCLUDES', 'includes/');

 define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

 define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

 define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

 define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

 define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');



 define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');

 define('DIR_FS_CATALOG', 'c:/Inetpub/wwwroot/hitryus/catalog/');

 define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');

 define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

 

etc, etc, etc...

 

define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'

 

anyone see any problems?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...