Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Doesn't Remember I'm Logged In


xtremelyfit

Recommended Posts

I have had a perfectly good working site and oscommerce cart for the last two months. My webhost got a new server and installed MS2. I have restored my database to this new server and new cart and everything works except that the cart won't remember that a customer has logged in. I log into My Account then add an item to the cart and click on Checkout and it takes me back to Log in again, and when I log in again I get the ubiquitous CGI Error ... I know it must be something simple, but I'm just not good at php yet - any help appreciated.

Link to comment
Share on other sites

I thought of that, but the web host installed the cart on the new server and all the settings in config.php look right. I"ve noticed that I can login if I just go to myaccount and login first. But if I put an item in the shopping cart first and click on check out and it takes me to the login screen and then I try to login that's when I get the CGI error

Link to comment
Share on other sites

So there are a couple of things happening:

1. If I login first thing it brings up my account info just fine. But then if I go to buy something and click on checkout it takes me back to the login screen even though I already logged in. At that point if I try to login again I get the CGI error.

 

2. If I don't login first thing and just try and buy something, click on checkout it takes me to login and when I try to login it gives me the CGI error.

 

All the settings in the configure.php file look correct.

 

I don't have this problem on the old server.

Link to comment
Share on other sites

sorry, there are 4 lines regarding cookies

 

define('HTTP_COOKIE_DOMAIN', 'www.xtremelyfit-supplements.com');

define('HTTPS_COOKIE_DOMAIN', 'www.xtremelyfit-supplements.com');

define('HTTP_COOKIE_PATH', '/shop/catalog/');

define('HTTPS_COOKIE_PATH', '/shop/catalog/');

 

 

I noticed that these are not in my 2.2 CVS (7.5.03 snapshot version) that I'm running on the old server. It all works fine on the old server without the cookie domains and paths.

Link to comment
Share on other sites

I fixed the problem by commenting out the four lines relating to cookies in the configure.php file.

 

Now my only problem is the right column on most of the pages doesn't want to stay out to the right margin - it moves into close to the text. Ever seen that happen?

Link to comment
Share on other sites

Well maybe you should get the configure files correct, i am not sure commenting them out is a great idea.

 

As long as new customers can order etc..

 

I wouldnt worry too much about the right hand side border too much, cant people just make the window bigger.

Link to comment
Share on other sites

I guess my problem is I don't know what's wrong with the configure.php file. These 4 cookie lines are new the frozen 7/12/03 MS2 version - they aren't in the

7/5/03 snapshot version I am using that is working fine.

 

Also, it's not a matter of making the window bigger on the other problem. Everything is squeezed over to the left leaving a lot of blank space on the right. You can see what I mean by going to www.xtremelyfit-supplements.com

Link to comment
Share on other sites

Your secure server address is:

 

https://calan.calantechnologies.com/xtremelyfitsup

 

correct this in your configuration files - including the https cookie domain

Link to comment
Share on other sites

You said

Your secure server address is:

 

CODE

https://calan.calantechnologies.com/xtremelyfitsup

 

correct this in your configuration files - including the https cookie domain

 

Thanks - I just went in and did this but it didn't help. I have done something else prior to your post. In order to correct the page formatting problem I was having with column_right moving way over to the left on most of my pages someone suggested that I set "Force Cookies" to true. I did that and it corrected ALL the formatting problems, but now when I click on My Account or Checkout it gives me the "CGI Error

The specified CGI application misbehaved by not returning a complete set of HTTP headers. The headers it did return are:" error. In other words I can't shop. Prior to setting the "Force Cookies" to true I could go to My Account and Checkout, etc.

 

Any more ideas? I really do appreciate your help.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...