Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

my UPS boondoggle


Guest

Recommended Posts

I am in need of severe help; I have tried everything in the book when it comes to trying to get ANY UPS release to work.

I have followed step by step ALL instructions and tried every workaround that I found on these boards to no avail. I am new to PHP and XML and pretty much everything else.

My config/shipp info is fine

I have tried all UPS contributions including the XML (the one I figured would do the trick)

I am really at a loss here as this is pretty much my last obstacle to pass before I can really start some testing to work everything out.

I have been trying to figure this out for a week.

:?:

Link to comment
Share on other sites

Are you in the US? Did you follow the installation instructions exactly? Including getting the aproperate ID and stuff from UPS? Is your osC installation - basic/un"mod"ified/not heavly changed?

 

If you answered NO to anything above - then re-read and re-do as per the instructions and make nessary changes. Start with a "Standard" installation and see if that works first.

Link to comment
Share on other sites

Thanks for the response, I am in the USA and have all proper accounts with UPS in line (access key, Dev Key) I have tried everything you mentioned and am in the middle of my second complete reinstall, from wiping out the DB and making a new one, then just trying to getting shipping straight.

Thanks for your help

Link to comment
Share on other sites

I got the UPS_XML1.2 module working with OSC2.2 by viewing the error log:

 

You can enable logging which will record the request/response of the transactions. Look for and uncomment this line in upsxml.php:

 

//$this->logfile = '/tmp/upsxml.log';

 

 

Hope this helps. :blink:

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...