Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Help with my illitracy


illiterate

Recommended Posts

Hi Everybody,

I have installed oscommerce on my website, but it shows a warning at the top of the catalog/index.php that says, the session.auto_start is enabled in the php.ini file of the webserver. So none of the links in the page work. and a Fatal Error occures when I point to them:

 

Fatal error: Unknown(): The script tried to execute a method or access a property of an incomplete object. Please ensure that the class definition navigationhistory of the object you are trying to operate on was loaded _before_ the session was started in /home/mydomain/public_html/catalog/includes/application_top.php on line 309

------------

My Webserver owner says that he can not, disable the session.auto_start as long as some of his customers, need that to be enabled,

could anyone Help me?

Thanks.

Link to comment
Share on other sites

Have you tried this

 

Try adding this code at the beginning of your /catalog/includes/application_top.php file,  

 

Code:  

 

   ini_set('session.auto_start', '0');  

 

 

 

If it still doesn't work, you'll have to ask your host to disable the session.auto_start directive in the php config file (php.ini).  

 

HTH,  

VJ

 

copied from some result using search.

 

If your still having problems, what's your sites url and is it too much trouble to change hosts if you can them to change for you?

 

Roger

facts invariably distort the truth

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...