Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Please Help! SSL issues in admin and catalog


Guest

Recommended Posts

Hello all,

 

I have just set up my store @ http://www.unicomps.co.uk/catalog and enabled SSL.

 

I have correctly set up both configure.php files in the includes directories as per the instructions in the WIKI docs and also from information from previous messages in the forums.

 

My issue lies with 2 areas:

 

1. In the customer end of the catalog, after the customer logs in and after the checkout process the following message appears:

 

You are about to be redirected to a connection that is not secure... Do you wish to continue?

 

I have read on a previous topic that there is nothing that you can do about this as this issue is from the customer's computer having such warnings enabled in IE!

 

This is disabled in my IE yet I still get the message, and other OSC stores do not seem to be suffering from this - so any help in removing the message will be appreciated!

 

2. When I enable SSL for my admin area, I get the padlock showing that SSL is enabled BUT the store states that the admin area is not SSL enabled!

 

Furthermore, and more worringly, none of the images appear on the admin side! Some contributions also fail to work corectly!

 

My store is hosted by 1 & 1 (UK) and I have a shared SSL certificate already preinstalled by them. Also both the HTTP and HTTPS are symlinked.

 

Do you think the problems are due to an incorrect installation of the certificate?

 

Thank you in advance for any help

 

Regards,

 

Jit

 

PS tell me what you think of the store :lol: (though still very stock in design! :roll: )

Link to comment
Share on other sites

Hello again,

 

sorry to bump but I have found a solution in the forums to point 1 above - thought it might be useful to others!

 

For point 1 above please see the following topic:

 

http://www.oscommerce.com/forums/viewtopic.php?t=55132

 

Pay paticular attention to notes by Justin (aka JB)!

 

Thanks (and thanks to Justin!)

 

I'll keep looking for an answer to the images issue in admin - though I think it might be due to absolute/relative image path issues (or the need to copy all images to HTTPS directory - though because I have symlink I don't know how!)

 

Regards,

 

Jit

Link to comment
Share on other sites

sorry to bump but I have found a solution in the forums to point 1 above - thought it might be useful to others!
It's not a bump to post that you found the solution, and it certainly isn't a bump to post the solution (or a link to it, which is just as good). The main purpose of these forums is to record solutions to problems that people have and make them easy to find. The more threads that have the solution, or a link to a thread with the solution, the easier it is to search.

 

I've found that the images problem with shared SSL is usually related to your DIR_WS_CATALOG_IMAGES define. This needs to have the /secure.unicomps.co.uk in it if you are using SSL.

 

Note: it would help to know what images are having problems.

 

Thanks,

Matt

Link to comment
Share on other sites

Hello Matt,

 

Thanks for tip - I never noticed the DIR_WS_CATALOG_IMAGES part - so thanks again Matt!

 

Tried it but it doesn't seem to work :cry:

 

This is how I put the path for the images... have I done it wrong?

 

define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . '/sslrelay.com/secure.unicomps.co.uk/catalog/images/');

 

BTW The images that do not appear are the images corresponding to the products, categories and also the language icon.

 

Regards,

 

Jit

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...