Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Problems with Internet Explorer 6 on XP


Han

Recommended Posts

OCS 2.2 working correctly on Opera, but not functioning well on IE 6:

when putting product in shopping cart and then pushing "continue shopping", it shows empty cart. When "log in" and then "continue" - says "Welcome guest" and offer log in once more. So, totaly crazy.

 

Brothers and sisters I know that many of you have the same problems.

 

Did somebody find any solution?

Link to comment
Share on other sites

Did somebody find any solution?

Most switched to Linux or Mac OS X. ;) :lol:

 

Sorry, I could not resist. :P

 

OCS 2.2 working correctly on Opera, but not functioning well on IE 6:

when putting product in shopping cart and then pushing "continue shopping", it shows empty cart. When "log in" and then "continue" - says "Welcome guest" and offer log in once more. So, totaly crazy.

 

Brothers and sisters I know that many of you have the same problems.

I honestly have not heard of this problem before.

 

Have you installed all of the security patches and updates for IE6 and WinXP?

 

Do you have Force Cookies enabled in Admin ~ Configuration ~ Sessions but have IE set to disallow cookies?

"Great spirits have always found violent opposition from mediocre minds. The latter cannot understand it when a man does not thoughtlessly submit to hereditary prejudices but honestly and courageously uses his intelligence." - A. Einstein

Link to comment
Share on other sites

I am glad to hear that you were able to resolve the problem.

 

Thank you for posting the answer. I will certainly keep it in mind in case the question arises again.

"Great spirits have always found violent opposition from mediocre minds. The latter cannot understand it when a man does not thoughtlessly submit to hereditary prejudices but honestly and courageously uses his intelligence." - A. Einstein

Link to comment
Share on other sites

OCS 2.2 working correctly on Opera, but not functioning well on IE 6:

when putting product in shopping cart and then pushing "continue shopping", it shows empty cart. When "log in" and then "continue" - says "Welcome guest" and offer log in once more. So, totaly crazy.

 

BINGO! Thank you for mentioning this...I am having the same sort of problem. Mozilla (netscape 7) works great. But on MSIE (and I am running 5.0, a very old msie) if I log out or time out or the session ends for whatever reason then i have to close the browser else what you are describing happens.

 

There was one time where I removed all temporary files and flushed the cache and I was able to log in again and see the cart. But all other tries since then need the browser to be closed first. Its very repeatable. I've seen the developers say 'yes, you have to close your browser". I can accept that. But, how to warn the customer to do so if he redirects to "Welcome Guest" page????

 

Do we need a session variable that says 'USED_TO_BE_LOGGED_IN_NOT_LOGGED_IN_NOW_SO_GIVE_A_WARNING"????

:) Surely the answer is already there and is just a matter of tuning the cart.

Link to comment
Share on other sites

YAY!!!!!!!

 

OK, I AM AN IDIOT. The developers will laugh at this.

 

My cookie path for the NON-SECURE server was not identical to the cookie path for the SECURE server.

 

Both have exactly the same URL and cookie domain. But the cookie paths MUST MATCH.

 

The symptoms were masked by the fact that if I relaxed "force cookies" and all the other session settings then most browsers seemed to work A-OK. Except MSIE 5. I finally forced cookies again, setting everything to true in the admin sessions screen, and under these conditions started looking at cookie details - then I noticed the mismatch in configure.php.

 

I've now tested with Mozilla 1.1, Opera, Konqueror, and MSIE 5.0, all work just fine.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...