Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

I am really hate the way this Install works!!!!!!!!


GIZMO-XL

Recommended Posts

Well I have to say as a software developer I have never had this much trouble getting a software package to work in all my life.

 

I am using a hosting firm with a secure server and none of the install information about this package covers this type in install.

 

I can understand a product like this that is changing all the time may have a documentation problem, but because of that simple fact two things need to be key with respect to this project.

 

1) the install must work everytime and a detailed set of instructions needs to be created for this process. the configure.php file has no instructions in it and if it is not setup correctly nothing works.....

 

2) Because this software changes so much a better means of upgrades needs to be developed to keep users on a upgrade path.

 

At this point I have spent more than 72 hours on this and have not been able to make it work.

 

Normally I would move on to another package but I have to say this is a feature rich package and with as many people working on it I am sure it will be the best solution you can find but right now I just want to punch out my computer....LOL

 

So if anyone can help please jump in here!!!!

 

GIZMO-XL

Link to comment
Share on other sites

what exactly are you having problems with? My install was extremely smooth, using Apache, mySQL and the 2.2 release. All I needed basically was SQL DB name and password, and to change a few permissions

 

Did you check the wiki.oscommerce.com site yet? There's good tips there...

Link to comment
Share on other sites

Right on fastEddie.

 

Gizmo detailed problems are what this forum is for.

 

General gripes may be better of in the Chit Chat forum :?

 

roger

facts invariably distort the truth

Link to comment
Share on other sites

Right on fastEddie.

 

Gizmo detailed problems are what this forum is for.

 

General gripes may be better of in the Chit Chat forum :?

 

roger

 

This was not a gripe it is a fact about the install process in my world.

 

this is how things have to be setup in my world...

 

I have none secure path.../..../.../httpdocs/shop that does not have a admin subdir. this dir FS_DIR paths

 

then I have a path.../.../.../.../httpsdocs/shop/admin SSL area that has the admin subdir and this is the WS_DIR paths

 

both non secure and secure have include and idir

Link to comment
Share on other sites

sorry post was not complete ...

 

images dir's

 

I am on mysql the install could not find the file to create the database because the path it figures out on it's own was wrong. So I had to install the database myself. I am sure the problem is in the configure.php files in both of the include dir's. Now keep in mind this setup is a requirement of my hosting firm not my choice. If you know where I can find a setup instructions that works for this configuration let me know.

 

I would of thought that the values I entered during the setup would of been saved in the configure.php files but it was not. and I did not get any errors. At this point I can see the catalog but I can't get the admin programs to work it like it can't map the the secure server area.

 

if anyone else has had this kind of problem please chime in....

 

GIZMO-XL

 

I have installed many other packages without these problems on this server.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...