Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Almost there, but a pressing problem - help / crit please!


Guest

Recommended Posts

My site www.oohprettythings.com is almost ready to go, but I'm suffering a persistent problem.

 

On any of the category pages, such as

http://www.oohprettythings.com/index.php?cPath=31

there's a broken image. The source revealed in that image is in fact the source for the 'Ooh! What's This?' image on the left. I can't for the life of me get rid of the broken image, or even find where it comes from. I

 

Originally, the broken image gave the default thingy 'What's new here?', which was a title located in the index.php file. There was never any actual heading that said this, however. I tried fixing it by changing the 'What's new here?' to the image address and uploading the 'Ooh! What's This?' image. Now, I get the image I want, and a broken image with that address in it.

 

Please help!

 

 

Also, I will be putting a large image on my front page, between the 'welcome' text and the 'what's new' box. Do you think this will look good?

 

Any help (please make the instructions easy to follow!), comment or criticism is more than welcome. Please don't make it too harsh, though, because this image problem is annoying me so much I'm gonna cry!

 

Shannon

Link to comment
Share on other sites

The layout looks close to what it did before. At least change the default osCommerce colors. Also your images are way to big. Your "thumbnails" aren't thumbnails. You definately need to add more color, and make it more professional looking if you want people to stay even a minute at your site. I would start by editing the stylesheet.css file.

 

....just my thoughts

turtle power!

Link to comment
Share on other sites

You've set the font size for 'Ooh! New Pretty Things! ' way too small, so its showing as a tiny line.

 

Set the background colour for your infobox headers to white, so it doesn't show behind the corner gifs.

Link to comment
Share on other sites

Set the background colour for your infobox headers to white, so it doesn't show behind the corner gifs.

 

ignore that - it won't work. :( but you need to do something about your shopping cart header

Link to comment
Share on other sites

I dont understand what did you modify?

All I see is the infobox corners are rounded...

everything else is STOCK,

 

In my personal opinion, if I entered your site I would not stay for 2 sec.

 

your shopping cart infobox is all messed up.. but I think you already know that.

 

I would loose the product counter in the catagories box.

 

Add more colors, your shop is very dull,

 

I would go and edit the style sheet right away..

 

 

 

go here for help... www.wiki.oscommerce.com

 

you wanted my option, you got it. :-)

 

Digi

*Outlined in chalk everone looks the same*

 

Currently useing OSC 2.2 MS1

running on Apache/1.3.27 (Unix) (Red-Hat/Linux) mod_jk/1.2.0 mod_perl/1.26 PHP/4.3.3 FrontPage/5.0.2 mod_ssl/2.8.12 OpenSSL/0.9.6b

Link to comment
Share on other sites

The layout looks close to what it did before. At least change the default osCommerce colors. Also your images are way to big. Your "thumbnails" aren't thumbnails. You definately need to add more color, and make it more professional looking if you want people to stay even a minute at your site. I would start by editing the stylesheet.css file.  

 

....just my thoughts

 

I like the default blue colour, because it matches my blue and pink heading.

 

I think I fixed the thumbnail issue...

 

How do I add more colour - I'm not confident in editing the stylesheet file, given past 'mishaps'. I have a vision, but am not sure how to 'do' it.

 

Specific instrucitons would be great!

Link to comment
Share on other sites

Warning: Cannot modify header information - headers already sent by (output started at /home/maisy/public_html/includes/languages/english.php:336) in /home/maisy/public_html/includes/functions/general.php on line 29

 

This is a recurring issue with my shipping and my account pages. Ben 'fixes' it, and then the next time I access the site it's buggered. Instructions would be waaay helpful!

 

About the small text on the front page - I want to remove that altogether as I don't want another heading.

 

Thanks for all your help and comments guys

Link to comment
Share on other sites

 

Set the background colour for your infobox headers to white, so it doesn't show behind the corner gifs.

 

I've tried, but can't work it out. Wiki doesn't seem to want to tell me what I need to know! (Looks around for guidance...)

Link to comment
Share on other sites

Set the background colour for your infobox headers to white, so it doesn't show behind the corner gifs.

 

ignore that - it won't work. :( but you need to do something about your shopping cart header

 

I think perhaps what you need to do is change boxes.php to add valign='top' to the line with the corner gifs.

Link to comment
Share on other sites

The image in the center of the welcome page makes the shop wider than my screen. Considering that my browser window is about 1100 pixels wide, I suspect that others will have trouble as well.

 

Hth,

Matt

Link to comment
Share on other sites

I can't find the code you mentioned in the file! I want to move the whole shopping cart thing from the right to the left hand side, and fix the buggered up heading on it. I think I fixed the image - I was uploading and testing them because I had no idea what size to make it.

Link to comment
Share on other sites

this is in regard to the recurring error you are having -- Warning: Cannot modify header information - headers already sent by (output started at /home/maisy/public_html/includes/languages/english.php:340) in /home/maisy/public_html/includes/functions/general.php on line 29

 

 

did you modify this block of code? it is in the /home/maisy/public_html/includes/functions/general.php file.

 

// Redirect to another page or site

function tep_redirect($url) {

if ( (ENABLE_SSL == true) && (getenv('HTTPS') == 'on') ) { // We are loading an SSL page

if (substr($url, 0, strlen(HTTP_SERVER)) == HTTP_SERVER) { // NONSSL url

$url = HTTPS_SERVER . substr($url, strlen(HTTP_SERVER)); // Change it to SSL

}

}

 

header('Location: ' . $url);

 

tep_exit();

}

 

////

 

Or did you just modify the copyright info in the english.php file?

 

I would like to help you if I can, but I need more info - paste the changes you made in the english.php file here so we can see what you did with it please. :)

Link to comment
Share on other sites

Errors stating 'cannot modify header information' are almost always nothing to do with the lines referenced in the error message. The problem is usually that there are blank spaces at the end of one of the two files mentioned. Delete the spaces & everything should work fine.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...