Jump to content
  • Checkout
  • Login
  • Get in touch


The e-commerce.

Please Help


Recommended Posts



I get this error

Warning: session.auto_start is enabled - please disable this php feature in php.ini and restart the web server.


When i launch the catalog the first time.

When I launch it the second time, i get this


Fatal error: Unknown(): The script tried to execute a method or access a property of an incomplete object. Please ensure that the class definition <b>navigationhistory</b> of the object you are trying to operate on was loaded _before_ the session was started in /data/www/r/rev-products/www.rev-products.com/htdocs/catalog/includes/application_top.php on line 309


I've a feeling those 2 errors are tied up

im not sure

i need professional help.


I have apache, php, mysql and everything i need for this program, installation went smooth and steady, but i get that error


pls pls help



Link to comment
Share on other sites

Open your php.ini file (should be in c:windows) and make sure your

; Initialize session on request startup.

session.auto_start = 0

is like this and restart your server




Link to comment
Share on other sites

  • 8 months later...

After wresting briefly with this problem, I found the solution. The problem is that in some configurations (at least mine), the navigation history section in "application_top.php" doesn't catch the possibility that the session "navigation" variable is registered and the PHP version running is 4 or above. I'm really not quite sure what caused this huge oversight on the part of the developers (with all due respect).


Change the nagivation history chunk of code to read:


// navigation history
 if (tep_session_is_registered('navigation')) {
   if (PHP_VERSION < 4) {
     $broken_navigation = $navigation;
     $navigation = new navigationHistory;
   } else {
	 $navigation = new navigationHistory;
 } else {
   $navigation = new navigationHistory;


and it should work just fine.

Link to comment
Share on other sites

Thank you! Exactly what I needed, now my site is working fine again. The only other thing I did was comment out the (check session.auto_start is disabled) section in includes/header.php





Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...