Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

footer.php showed badly...


Guest

Recommended Posts

Hi Piotr

 

I have the same problem. From 3 days ago, the banner at the bottom of the site doesn't work properly at first load.

 

I have tried it in many browsers, and other PC's, they are all the same. at first time I load my catalog, the banner and the footer will show up on the left side best the products. Then If I reload the page it will look fine. But the first time never works.

 

If anyone knows how to solve that please let us know.

 

Thanks. :!:

Link to comment
Share on other sites

I think I found the bug.

 

You see if you change any of the products, the page structure will stay the same. "the fact that footer is on the right side at first load".

 

But if you turn your special off, it will work in most browsers but not in all ie versions yet. the currency still has some bugs. Try playing with the special that you have and see if that solves the problem. Turn it on and off in admin.

 

I did that for my website, and it fixed the footer. But then it keep showing up on the right side if I turn special back on.

 

This is probably a bug associated with specials and footer. and perhaps the size of the our pictures.

 

Let me know what happens to yours.

 

thanks

 

mike.

Link to comment
Share on other sites

I had the same problem, apparently it is a php bug and someone gave me a link to a fix. But I can't find the thread anymore. What I did to fix it was edit the .htacces file and change line 33 from

 

# php_value session.use_trans_sid 0

 

to this

 

php_value session.use_trans_sid 0

 

and it fixed it.

Link to comment
Share on other sites

hi chris

 

thanks for your reply.

 

I tried editing the .htaccess but there are only 10 lines in there. Maybe its because is the new version. Ans my second problem was that I couldn't write into it. Although I fixed the permission settings via my ftp. I am going to try posting this problem again to see if anyone else can figure something out.

 

 

Thanks.

Link to comment
Share on other sites

thank you so much.

 

hey piotrek, in admin I changed my cookie, to true and it is all gone. the footer is now in its place. Go to admin, config, sessions, set cookie to true.

 

Thank you all for your support. specially solardirect.

Link to comment
Share on other sites

You may want to consider another solution for your problem as a long term fix instead of the force cookies. Do you realize that many people have cookies turned off so they will get a message telling them to turn cookies on for your site, which may drive people away.

 

There are other solutions if you read the thread above carefully.

 

Also, consider posting to http://www.oscommerce.com/forums/viewtopic.php...ions%2A+spiders

://http://www.oscommerce.com/forums/viewto...s%2A+spiders

to help get this other important topic answered as it effects everyones sites.

Boom... Big butta boom.

Link to comment
Share on other sites

Kirk you are absolutely right. Thanks for the advice.

 

I changed the force cookie for false. and added a <table> to the begining of the footer.php and it solved all the problems.

 

Right On.

 

Thanks again.

 

Mike

Link to comment
Share on other sites

Sorry I meant to say I added a closed table </table> to the begining of the file footer.php .

 

Just to clear that; so no one else adds a <table> instead of </table>

Link to comment
Share on other sites

  • 2 weeks later...

Thank you for suggesting adding </table> it works perfectly, I had been having no luck at all with the .htacces file suggestions and was unable to update php on my remote server.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...