Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Sorry but this is a big detailed post!!!!!!!!


Jellyman_4eva

Recommended Posts

Hi everybody,

 

I have now tried everything to make this work so I am now going to put every detail I can in to sort it out!!!

 

Catalog is fine, secure at checkout etc, no problem!! What I want is a secure SSL admin area. So I have edited the configure file in:

 

/ public_html / catalog / admin / includes /

 

To this:

 

<?php

/*

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

Copyright © 2003 osCommerce

 

Released under the GNU General Public License

*/

 

// Define the webserver and path parameters

// * DIR_FS_* = Filesystem directories (local/physical)

// * DIR_WS_* = Webserver directories (virtual/URL)

define('HTTP_SERVER', 'https://www.securesite11.com/~artist'); // eg, http://localhost - should not be empty for productive servers

define('HTTP_CATALOG_SERVER', 'http://www.artist-bears.com');

define('HTTPS_CATALOG_SERVER', 'https://www.securesite11.com/~artist');

define('ENABLE_SSL_CATALOG', 'true'); // secure webserver for catalog module

define('DIR_FS_DOCUMENT_ROOT', '/home/artist/public_html/catalog/'); // where the pages are located on the server

define('DIR_WS_ADMIN', '/catalog/admin/'); // absolute path required

define('DIR_FS_ADMIN', '/home/artist/public_html/catalog/admin/'); // absolute pate required

define('DIR_WS_CATALOG', '/catalog/'); // absolute path required

define('DIR_FS_CATALOG', '/home/artist/public_html/catalog/'); // absolute path required

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');

define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');

define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');

define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');

define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');

 

artist-bears.com is the website which I am have hosted by prowebspace.com and securesite11.com is the shared SSL area I have been given with the prefix /~artist for my area.

 

OK, now when I try go to www.artist-bears.com/catalog/admin I get this error.

 

Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /home/artist/public_html/catalog/admin/includes/configure.php:47) in /home/artist/public_html/catalog/admin/includes/functions/sessions.php on line 67

 

And when I go to click on administration, a box comes up about the security certificate, which is ok, it then goes into SSL but never takes me anywhere, just back to where I started, with these errors!

 

Warning: session_start(): Cannot send session cookie - headers already sent by (output started at /home/artist/public_html/catalog/admin/includes/configure.php:48) in /home/artist/public_html/catalog/admin/includes/functions/sessions.php on line 67

 

Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /home/artist/public_html/catalog/admin/includes/configure.php:48) in /home/artist/public_html/catalog/admin/includes/functions/sessions.php on line 67

 

AGGGGGGHHHHHHHHHHHHHHH!

 

My other problem is I want it so that even when I type in the admin address:

 

http://www.artist-bears.com/catalog/admin/

 

It automatically jumps into SSL mode, before asking me for my username and password which I shall put on the admin folder!!

 

PLEASE PLEASE PLEASE HELP SOMEBODY OR ELSE I MAY ACTUALLY DIE

 

Thanks

Link to comment
Share on other sites

Try this:

 

define('HTTP_SERVER', 'https://www.securesite11.com/~artist'); // eg, http://localhost - should not be empty for productive servers 

define('HTTP_CATALOG_SERVER', 'https://www.securesite11.com/~artist'); 

define('HTTPS_CATALOG_SERVER', 'https://www.securesite11.com/~artist'); 

define('ENABLE_SSL_CATALOG', 'true'); // secure webserver for catalog module

 

My other problem is I want it so that even when I type in the admin address:

 

http://www.artist-bears.com/catalog/admin/

 

It automatically jumps into SSL mode, before asking me for my username and password which I shall put on the admin folder!!

 

That is not an SSL address ie "http://" v. "https://" so of course it is not going to be secure as you are calling up a non SSL page. Try the above change and then type in this (or whatever the correct path would be) to gain access to your panel:

 

https://www.securesite11.com/~artist/catalog/admin/

Link to comment
Share on other sites

Change this line-

 

define('ENABLE_SSL_CATALOG', 'true'); // secure webserver for catalog module

to-

 

define('ENABLE_SSL_CATALOG', 'false'); // secure webserver for catalog module

 

That should turn off the SSL when you first visit your site.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...