Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

OSC Affiliate problem.


stoo2000

Recommended Posts

ON the affiliate_sales.php page its giving me

 

Warning: Missing argument 3 for splitpageresults() in /home/silveste/public_html/testarea/osc/includes/classes/split_page_results.php on line 24

 

Warning: Missing argument 4 for splitpageresults() in /home/silveste/public_html/testarea/osc/includes/classes/split_page_results.php on line 24

 

this is only doing this on this page (and maybe the clicktrhough page)

 

the affiliate prog is saying there is a sale but its not listing it when the affiliate logs in.

 

Please help, this is one of the things holding the release of my new site up.

Stuart

Link to comment
Share on other sites

Hi,

 

having had a problem with Splitpageresults with another contrib and an MS2 store this afternoon, I know that there can be some problems in this area.

 

The arguments for this function have changed a little with MS2 and so it prompts me to ask the questions:

 

Which osC version are you using?

 

and

 

Are you using the correct version of osC Affiliate for your osC version?

 

Regards,

 

 

 

Mark

Link to comment
Share on other sites

This then I think is the cause of the problem as the latest release of osC Affiliate is designed for MS2.

 

Regards,

 

 

 

Mark

Link to comment
Share on other sites

  • 8 months later...

Hi Equilla

 

I had the same problem, and I simply substitute the split_page_results.php (v. 1.11) with the split_page_results.php (v. 1.15).

All seems to work good....

 

Do you think this can create many problems?

Link to comment
Share on other sites

Sure!!! many problems!! :rolleyes:

 

So, i have found a new solutions:

1) upload the split_page_results.php (v. 1.15) and renamed split_page_results_2.php (leaving split_page_results.php (v. 1.11))

2) create a new application_top.php and name it: application_top_2.php

3) In the application_top_2.php substitute the line

 

// split-page-results

require(DIR_WS_CLASSES . 'split_page_results.php');

 

with this:

 

// split-page-results 2

require(DIR_WS_CLASSES . 'split_page_results_2.php');

 

Ok! Now, in the files where you have the error, (affiliate_clicks.php, affiliate_sales.php, affiliate_payment.php) substitute the line:

 

require('includes/application_top.php');

 

with:

 

require('includes/application_top_2.php');

 

E il gioco ? fatto!! :D All it works!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...