Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Import trouble with Easy populate 2.61.2


Qbaze

Recommended Posts

Hi

After installing and configure Easy populate I get an error when I try to upload and insert my text-file to db.

Here is the message:

-----------------------------------------------------------------------------------

File uploaded.

Temporary filename: /tmp/phpwgGaxF

User filename: Network komponent redigerad 030816.txt

Size: 165876

| 252050 | | CDRW Phili | PCRW4816K/ | http://www | | | | CDRW Phili | | http://www | | | | 494 | | 0000-00-00 | 2003-08-14 | | | H?rdvara | CD, CD- RW | | | !New Product!

1054 - Unknown column 'products_head_title_tag' in 'field list'

 

INSERT INTO products_description (products_id, language_id, products_name, products_description, products_url, products_head_title_tag, products_head_desc_tag, products_head_keywords_tag) VALUES ( '28', 4, 'CDRW Philips, PCRW4816K/20 CDRW Silver', '', 'http://www.philips.se', '', '', '')

 

[TEP STOP]

 

-----------------------------------------------------------------------------------

 

The first product seems to come in to db but not the rest.

When I look in Catalog, my new catageries are their, but not the product? :shock:

I have put EOREOR on last row on each of the products

 

I am not so good at the php scripting language so its hard to troubleshoot.

 

Any help or pointers is appreciated

:?:

Regards Qbaze aka Andreas

I plan to write something smart down here.....

Link to comment
Share on other sites

You must comment out the following fields in easypopulate.php

 

products_head_title_tag

products_head_desc_tag

products_head_keywords_tag

 

INSERT INTO products_description (products_id, language_id, products_name, products_description, products_url) VALUES ( '28', 4, 'CDRW Philips, PCRW4816K/20 CDRW Silver', '', 'http://www.philips.se')

Link to comment
Share on other sites

I'm having the same problem but don't quite understand how to complete the fix. Could I get a bit more detail on the commenting out part?

Link to comment
Share on other sites

Comment out heaer controller tags as:

 

$filelayout = tep_array_merge($filelayout , array(

'v_products_name_' . $l_id => $iii++,

'v_products_description_' . $l_id => $iii++,

'v_products_url_' . $l_id => $iii++,

#'v_products_head_title_tag_'.$l_id => $iii++,

#'v_products_head_desc_tag_'.$l_id => $iii++,

#'v_products_head_keywords_tag_'.$l_id => $iii++,

));

Link to comment
Share on other sites

I'm getting something wierd:

 

1054 - Unknown column 'cd.categories_heading_title' in 'field list'

 

select cd.categories_name, cd.categories_heading_title, cd.categories_description, c.categories_image from categories c, categories_description cd where c.categories_id = '111' and cd.categories_id = '111' and cd.language_id = '1'

 

[TEP STOP]

 

 

Any clues. I've been looking for info all morning :oops:

Link to comment
Share on other sites

  • 2 weeks later...

Hi there i am getting same sort of error but i think it has to do something with my db i am using OSC MilStone2 but the field p.products_model is not there only products_model.

 

Can somebody help me?

 

1054 - Unknown column 'p.products_model' in 'field list'



SELECT p.products_id as v_products_id, p.products_model as v_products_model, p.products_image as v_products_image, p.products_price as v_products_price, p.products_weight as v_products_weight, p.products_date_added as v_date_avail, p.products_tax_class_id as v_tax_class_id, p.products_quantity as v_products_quantity, p.manufacturers_id as v_manufacturers_id, subc.categories_id as v_categories_id FROM products as p, categories as subc, products_to_categories as ptoc WHERE p.products_id = ptoc.products_id AND p.products_model = '' AND ptoc.categories_id = subc.categories_id

Link to comment
Share on other sites

Ok, glad i'm not the only one with this problem. Weird thing is i installed on one database no problems, then on another database (same hosting machine) I get same above error.

 

I also have not installed "header controller contribution" but on the second installation I have installed the "Australia post contribution" also in the "easypopulate.php" I set "$modelsize = 32" and "$price_with_tax = true;"

 

I have also turned on tax and a few other changes in the configuration pages. But would/should any of these cause the error that is happening.

 

This is what i am getting.

 

File uploaded. 

Temporary filename: /tmp/phplPmsmH

User filename: EP2003Sep05-15033.xls

Size: 95133

| MG200MMS | matrox/mg2 | Matrox G20 | Reinforcin | www.matrox | | | | 329.99 | 23.00 | 0000-00-00 | 0000-00-00 | 32 | Matrox | Hardware | Graphics C | | Taxable Go | Active Updated

1054 - Unknown column 'products_head_title_tag' in 'field list'



UPDATE products_description SET products_name = 'Matrox G200 MMS', products_description = 'Reinforcing its position as a multi-monitor trailblazer, Matrox Graphics Inc. has once again developed the most flexible and highly advanced solution in the industry. Introducing the new Matrox G200 Multi-Monitor Series; the first graphics card ever to support up to four DVI digital flat panel displays on a single 8" PCI board.



With continuing demand for digital flat panels in the financial workplace, the Matrox G200 MMS is the ultimate in flexible solutions. The Matrox G200 MMS also supports the new digital video interface (DVI) created by the Digital Display Working Group (DDWG) designed to ease the adoption of digital flat panels. Other configurations include composite video capture ability and onboard TV tuner, making the Matrox G200 MMS the complete solution for business needs.



Based on the award-winning MGA-G200 graphics chip, the Matrox G200 Multi-Monitor Series provides superior 2D/3D graphics acceleration to meet the demanding needs of business applications such as real-time stock quotes (Versus), live video feeds (Reuters & Bloombergs), multiple windows applications, word processing, spreadsheets and CAD.', products_url = 'www.matrox.com/mga/products/g200_mms/home.cfm', products_head_title_tag = '', products_head_desc_tag = '', products_head_keywords_tag = '' WHERE products_id = '1' AND language_id = '1'



[TEP STOP]

 

I assume the same fix will work for me so i will try that. Jope someone can shed some light on this problem.

 

Regards

Blowfish[/code]

Regards

Brett

Design Manager

Blowfish Design

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...