Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Cant seem to install this (Newbie question)


Guest

Recommended Posts

Ok I am trying to install this and cant seem to do this. This is what I did can anyone tell me where I went wrong.

 

I unzippped the package.

 

Created a new direcotry on my host called oscommerce-2.2ms2 which gave me http://myhost.com/oscommerce-2.2ms2

 

I uploaded the catalog dir which gave me http://myhost.com/oscommerce-2.2ms2/catalog

 

The admin area was in the catalogue file which i renamed to a unique name.

 

When I went to http://myhost.com/catalog/install I got an error page.

 

 

Can anyone see where I am going wrong?

Link to comment
Share on other sites

also some hosts take a while to get round allowing you to see your new pages! I agree tho' you need to type http://www.yourhost.com/osCommerc.../catal...all/install.php into your browser to get to theGUI. Also make sure you have configured write permissions (CHMOD) on the configuration.php files (as outlined in these forums) or else the admin section won't run after installation. Permissions usually configured via FTP programme.

:idea: :arrow: :twisted:

Mark

Link to comment
Share on other sites

also some hosts take a while to get round allowing you to see your new pages! I agree tho' you need to type http://www.yourhost.com/osCommerc.../catal...all/install.php into your browser to get to theGUI. Also make sure you have configured write permissions (CHMOD) on the configuration.php files (as outlined in these forums) or else the admin section won't run after installation. Permissions usually configured via FTP programme.

:idea: :arrow: :twisted:

Mark

Link to comment
Share on other sites

I reuploaded it to my host as www.myhost.com/catalog rather than http://www.myhost.com/oscommerce-2.2ms2/catalog

 

I still have no luck when going to http://www.myhost.com/catalog/install/install.php

 

I will give it 12 hours or so to see if it is just my server which is slow to update. I wouldnt understand what to do if it is a problem with the config file.

 

Can anyone give me any advice where am I going wrong.

 

Lee

Link to comment
Share on other sites

How are you uploading your files?

If you are using an FTP programme then in the 'distant' directory you right click on the file you want to change the attributes of and pick attributes/chmod from the options.

The files that need to have a value of 777 (can write to them) for installing are /catalog/admin/includes/configure.php and /catalog/admin/includes/configure.php.

Remember to change them back afterwards!

These files must be writeable during the install process so if you have already installed I would suggest you run it again.

 

Am online for the next couple of hours so I am happy to have a look at your site and help out if you PM me the details

Mark

Link to comment
Share on other sites

Also - make sure that your webspace has the index root set to the root directory of your site (ie www.myhost.com) and not the catalog directory or else when you type in www.myhost.com/catalog/install/ your webspace will be looking for a directory called 'root'/catalog/catalog/install/ which won't exist.

:idea: :arrow: :oops:

Mark

Link to comment
Share on other sites

Ok,

 

I am a little further than i was. I have managed to upload it all. I managed to start the installation via a web broser. I put in the correct database details but I am now stuck on step 7 of install. I get this error message: New Installation

 

osCommerce Configuration

 

The following error has occurred:

 

 

The configuration files do not exist, or permission levels are not set.

 

Please perform the following actions:

cd /home/sites/site183/web/catalog/includes/

touch configure.php

chmod 706 configure.php

cd /home/sites/site183/web/catalog/admin/includes/

touch configure.php

chmod 706 configure.php

 

If chmod 706 does not work, please try chmod 777.

 

If you are running this installation procedure under a Microsoft Windows environment, try renaming the existing configuration file so a new file can be created.

 

 

Can ayone help? where am I going wrong what can I do? my msn messager address is [email protected] if anyone has a few spare minutes to talk me through it. All help is much appreciated.

 

Cheers

 

Lee

Link to comment
Share on other sites

You need to do the file attributes chmod value changes as before with the files the error message is giving you

:idea: :arrow: :lol:

Mark

Link to comment
Share on other sites

How?

 

what do i set them to how do i set them? I am using an ftp program

 

do i right click properities?

 

what do i set them to?

Link to comment
Share on other sites

using an FTP programme you right click on the file you want to change the attributes of in the 'distant' browser window. A menu will appear with 'attributes' or 'chmod' as one of the options - pick it and set the value to 777 (all read/write)

:arrow: :arrow: :shock:

Link to comment
Share on other sites

Your not doing anything wrong, you just need to change the permissions, just like the message said.

 

Just a note to say that CuteFTP is fine, but WSFTP Lite doesn't have a chmod option.

 

If you have cpanel or some other control on your host then there's a file manager there that will change permissions. Permissions/chmod are the same thing.

 

You should change them back to whatever (644 or 704) to stop external acces after.

 

Roger

facts invariably distort the truth

Link to comment
Share on other sites

Hello, I am trying to install the cart. I have gotten everything uploaded. I get to step 2 of the install. I enter my info but when I go to step 3 it tells me it can't connect to the db server. any suggestions??

Link to comment
Share on other sites

make sure you have a db to connect to and that you have the correct path and name/password etc details

you will need to check this with your webhosting company

often you have to enable the database through your webspace control panel before it can be accessed

:arrow: :idea: :wink:

Mark

Link to comment
Share on other sites

How?

 

what do i set them to how do i set them? I am using an ftp program

 

do i right click properities?

 

what do i set them to?

 

You find the file the installation is telling you to find, right click on it, then find somethat like "permissions" or "file attributes". Then enter the number that the installation is telling you to enter.

Link to comment
Share on other sites

have you read www.wiki.oscommerce.com, if not do it now. this stuff is exdplained and that's what it's there for.

 

Step 2

 

server: localhost (not ip number or url)

 

user name : the name you have to access your database

 

password: to access the data base

 

 

database name: the name of the database you created before installing??

 

Read wiki as above, it's all there, it will save a lot of your and the forums time if you spend half an hour reading it.

facts invariably distort the truth

Link to comment
Share on other sites

And also, there are some nessesary steps at the end of the wiki documentation that are not mentioned in the installation, so you will have to read it either way.

Link to comment
Share on other sites

Yes I had it on the screen as I was doing the install, But it was the fact that I was trying to use the ip instead of local host. Sorry for my ignorance!! After I finished the install however I got this

 

New Installation

 

osCommerce Configuration

 

 

Warning: fopen("/usr/local/psa/home/vhosts/maysville-usa.com/httpdocs/catalog/admin/includes/configure.php", "w") - No such file or directory in /usr/local/psa/home/vhosts/maysville-usa.com/httpdocs/catalog/install/templates/pages/install_7.php on line 259

 

Warning: fputs(): supplied argument is not a valid File-Handle resource in /usr/local/psa/home/vhosts/maysville-usa.com/httpdocs/catalog/install/templates/pages/install_7.php on line 260

 

Warning: fclose(): supplied argument is not a valid File-Handle resource in /usr/local/psa/home/vhosts/maysville-usa.com/httpdocs/catalog/install/templates/pages/install_7.php on line 261

The configuration was successful!

 

 

 

can you elaborate the meaning of this please??

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...