Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

My links refer to wrong filesnames.


Marco from Holland

Recommended Posts

Hello,

 

I've just run through the installation, but now the links refer to the wrong pages. I checked the configuration files, but there are no easy to spot mistakes.

 

All links show double filenames:

 

http://members.lycos.nl/biketravel/install...talog/......etc (can't read this far because it doesn't fit in the window)

 

I already deleted the install folder, but it didn't make any changes.

 

Where did I go wrong???

Link to comment
Share on other sites

There seems misconfigurations. Please look into or post "/catalog/includes/configure.php" .

 

Ofcourse hide the password before posting :wink:

 

kagg

Link to comment
Share on other sites

My configure.php looks like this:

 

// Define the webserver and path parameters

// * DIR_FS_* = Filesystem directories (local/physical)

// * DIR_WS_* = Webserver directories (virtual/URL)

define('HTTP_SERVER', '://'); // eg, http://localhost - should not be empty for productive servers

define('HTTPS_SERVER', ''); // eg, https://localhost - should not be empty for productive servers

define('ENABLE_SSL', false); // secure webserver for checkout procedure?

define('HTTP_COOKIE_DOMAIN', 'members.lycos.nl');

define('HTTPS_COOKIE_DOMAIN', '');

define('HTTP_COOKIE_PATH', '/catalog/');

define('HTTPS_COOKIE_PATH', '');

define('DIR_WS_HTTP_CATALOG', 'members.lycos.nl/biketravel/catalog/');

define('DIR_WS_HTTPS_CATALOG', '');

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 

define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');

define('DIR_FS_CATALOG', '/data/members/free/tripod/nl/b/i/k/biketravel/htdocs/catalog/');

define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');

define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

 

// define our database connection

define('DB_SERVER', 'localhost'); // eg, localhost - should not be empty for productive servers

define('DB_SERVER_USERNAME', 'biketravel');

define('DB_SERVER_PASSWORD', '');

define('DB_DATABASE', 'biketravel_nl_db');

define('USE_PCONNECT', 'true'); // use persistent connections?

define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'

?>

Link to comment
Share on other sites

Try changing the values og HTTP_SERVER and HTTPS_SERVER as follows:

 

define('HTTP_SERVER', 'http://members.lycos.nl/biketravel'); // eg, http://localhost - should not be empty for productive servers

define('HTTPS_SERVER', 'http://members.lycos.nl/biketravel'); // eg, https://localhost - should not be empty for productive servers

 

kagg

Always make a backup before modifications :)

Link to comment
Share on other sites

I also changed this:

define('DIR_WS_HTTP_CATALOG', 'members.lycos.nl/biketravel/catalog/');

and I changed it to

define('DIR_WS_HTTP_CATALOG', '/catalog/');

 

Which added the layout to the main page. (Which was pretty messy before)

 

But the links still have those double paths.

Link to comment
Share on other sites

Leave the fields blank as:

 

define('HTTP_SERVER', ''); // eg, http://localhost - should not be empty for productive servers

define('HTTPS_SERVER', ''); // eg, https://localhost - should not be empty for productive servers

 

Also try changing as

 

define('DIR_WS_HTTP_CATALOG', 'catalog/');

 

or

 

define('HTTP_COOKIE_PATH', 'catalog/');

 

kagg

Link to comment
Share on other sites

hmm....

 

Make it as before

 

define('HTTP_SERVER', 'http://members.lycos.nl/biketravel'); // eg, http://localhost - should not be empty for productive servers

define('HTTPS_SERVER', 'http://members.lycos.nl/biketravel'); // eg, https://localhost - should not be empty for productive servers

 

And try changing as

 

define('HTTP_COOKIE_DOMAIN', '');

 

Hope it will go now.

 

kagg

Link to comment
Share on other sites

The layout is back, but the double path is still there:

 

Http://members.lycos.nl/biketravel/catalog...talog/login.php

 

And the file looks like this now:

 

/ Define the webserver and path parameters

// * DIR_FS_* = Filesystem directories (local/physical)

// * DIR_WS_* = Webserver directories (virtual/URL)

define('HTTP_SERVER', 'members.lycos.nl/biketravel/'); // eg, http://localhost - should not be empty for productive servers

define('HTTPS_SERVER', 'members.lycos.nl/biketravel/'); // eg, https://localhost - should not be empty for productive servers

define('ENABLE_SSL', false); // secure webserver for checkout procedure?

define('HTTP_COOKIE_DOMAIN', '');

define('HTTPS_COOKIE_DOMAIN', '');

define('HTTP_COOKIE_PATH', 'catalog/');

define('HTTPS_COOKIE_PATH', '');

define('DIR_WS_HTTP_CATALOG', 'catalog/');

define('DIR_WS_HTTPS_CATALOG', 'catalog/');

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 

define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');

define('DIR_FS_CATALOG', '/data/members/free/tripod/nl/b/i/k/biketravel/htdocs/catalog/');

define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');

define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

 

// define our database connection

define('DB_SERVER', 'localhost'); // eg, localhost - should not be empty for productive servers

define('DB_SERVER_USERNAME', 'biketravel');

define('DB_SERVER_PASSWORD', '');

define('DB_DATABASE', 'biketravel_nl_db');

define('USE_PCONNECT', 'true'); // use persistent connections?

define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'

?>

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...