Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

How do I make OSC send order emails to...


k_budiarto

Recommended Posts

Need help (don't we all?).

 

How do I make OSC send order emails to various people (like, let's say, to order processing department people) when someone places an order?

 

I know OSC sends a copy of confirmation e-mail to Store Owner e-mail address and to whoever is in the list of "Send Extra Order Emails To", but that just sucks (excuse the language) because I want to change the content of that email so it says something like "An order has been placed online, get back to work and ship it immediately!!"

 

You get the idea.

Link to comment
Share on other sites

Hi! :D

 

Well open your checkout_process.php file and at the bottom you will find this code;

 

// send emails to other people

 if (SEND_EXTRA_ORDER_EMAILS_TO != '') {

   tep_mail('', SEND_EXTRA_ORDER_EMAILS_TO, EMAIL_TEXT_SUBJECT, $email_order, STORE_OWNER, STORE_OWNER_EMAIL_ADDRESS);

 }

 

below that paste this

 

// send emails to order processing team

 if (SEND_EXTRA_ORDER_EMAILS_TO != '') {

   tep_mail('', 'Order Processing <[email protected]>', 'An order has been placed online, get back to work and ship it immediately!', $email_order, STORE_OWNER, STORE_OWNER_EMAIL_ADDRESS);

 }

 

That should work, if not you might have to create a similar entry like SEND_EXTRA_ORDER_EMAILS_TO in the configuration table and specify the email addresses in there.

Reddy to Rumble

 

Thank you osCommerce and all who Contribute to her!

Link to comment
Share on other sites

Take out the if statement and just make it:

tep_mail('', 'Order Processing <[email protected]>', 'An order has been placed online, get back to work and ship it immediately!', $email_order, STORE_OWNER, STORE_OWNER_EMAIL_ADDRESS);

"Great spirits have always found violent opposition from mediocre minds. The latter cannot understand it when a man does not thoughtlessly submit to hereditary prejudices but honestly and courageously uses his intelligence." - A. Einstein

Link to comment
Share on other sites

  • 6 months later...

Hi,

 

In admin, i set Use MIME HTML When Sending Emails to = true.

 

For some reason the extra order emails sent to me are jumbled after doing so. They are ok when i turn it back to false. I need the setting to be on true, because sometimes the & ampersand will display as & on the customer's order confirmation and this confuses them, prompting them to contact me.

 

I'm sure this is an easy one, just had no luck finding an answer.

Thanks much!!

 

:D

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...