Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

FATAL ERROR: register_globals is disabled in php.ini


kucing

Recommended Posts

i have this error massage FATAL ERROR: register_globals is disabled in php.ini, please enable it! when trying to open any php file in the following directoryhttp://localhost/oscommerce-2.2ms2/catalog/

 

 

1) Do a search on your harddisk for "Php.ini"

2) Open it, and search for "register_globals", set it to "On".

 

Done.

 

Good Luck. :D

Link to comment
Share on other sites

how do you import your osCommerce into your sql database?what file name actually i can put in myphpadmin?

 

Follow the installation process screen, it will import for you. Have you read the installation guide yet?

 

Good Luck. :)

Link to comment
Share on other sites

If you are on a MSWin platform try looking for php.ini in the windowssystem or system directory (working on OSX at the moment so can't be 100%). The files you mention are copies; not your 'live' ini file . On OSX your look for php.ini using Termnal: /usr/local/php/lib

:)

Link to comment
Share on other sites

I changed both php INI.DIST file and php INI.RECOMMENDED file and set all register_globals from off to on and still have error massage when opening a page in my localhost

 

php INI.DIST file and php INI.RECOMMENDED

 

But you need to find php.ini.......

Link to comment
Share on other sites

I also have this message. I notice that the message is hard coded and I cannot find a file called php.ini anywhere.

 

I have restored a back-up but I still have the problem.

 

Can anyone please help.

 

Mark

Link to comment
Share on other sites

I have been trying to find this file all day.

 

I am a hosting reseller using 1fasthost they ahve a plesk administrator interface.

 

Can someone tell me hoe to find the file php.ini?

 

Thanks

Link to comment
Share on other sites

I would normally look in /etc, but it could be somewhere else. You could also ask your hosting company. They may not let normal users see it.

 

You might find some more suggestions by searching for *phpinfo*.

 

Hth,

Matt

Link to comment
Share on other sites

  • 2 years later...

I am having the same problem. I receive this message just like the other folks who have been writing:

 

FATAL ERROR: register_globals is disabled in php.ini, please enable it

 

I've researched this for the past three days, and I can't find an answer in how to resolve this issue. Can someone please help? Please?

 

Let me add I can't even find the php.ini file. I've searched all over tarnation and I can't find it.

 

Thank you, kbf.

Link to comment
Share on other sites

Okay, let's clear up a few points all at once.

 

If you are using osCommerce on a local install on your computer, and the computer uses a Windows operating system (98, 2000, XP etc) then you will find the php.ini file in c:\windows

 

If your site is hosted then you may (or you may NOT) have a local php.ini file that you have access to, somewhere like etc/php.ini

 

However, even if you have a local php.ini file this will get overwritten by the main server-wide php.ini file every time that is altered by your hosting company. So - install the Register Globals Patch Files - link below my name.

 

Anything you do in php.ini on your own computer won't affect an online website - because your own php.ini file is for your computer only.

 

Vger

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...