Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Installation help: permissions issues


reeflabs

Recommended Posts

Hey all,

Bit of a noob here...:)

Just uploaded my catalog file, had to rename all file extensions "php4" which was a real headache..:(

 

Now just tryin to Get to the install page, but I'm getting the old "Forbidden

You don't have permission to access /catalog/install/ on this server."

 

I'm using WS_FTP which does not give me the option of setting permission numbers, just shoosing between read, write, and exicute for three parties...admin, group, and others...HELP?!

 

I've played around with the permission settings for admin/includes/configure.php4 and includes/configure.php4 a lot with no real luck. What exactly should my permissions be (not numbers) for these files and any other permissions i should check in the directory structure. thx!!

Link to comment
Share on other sites

it also appears as though i could not even navigate into the catalog dir without setting permissions for the ENTIRE directory to read and write, and exicute. after which i am able to enter the dir, but hasn't that also changed the permissions for every file in that dir?

 

So am i to understand that the entire Catalog dir should be permissions read-only except for the two configure.php4 files?

 

sry for the noob q's:)

Link to comment
Share on other sites

see now that ws_ftp spits out the number settings in the output string text

 

So i set the whole catalog dir to 644, then went in and did the two config files to 777. Now Im getting a new error...basically a 404:

 

Not Found

The requested URL /catalog/install/ was not found on this server.

Link to comment
Share on other sites

i can't even navigat into the "catalog" dir without setting its permission to 777. Then once im in..i confirmed that both configure files have permissions 777.

 

I'm still getting a "Forbidden" error...403 i think. but when i don't get that, i get a 404 error?! lookin for a little help here..thx.

 

I'm running WinXP Pro

I'm usin WS_FTP

Link to comment
Share on other sites

ok..Im' playin with all kinds of permissions combinations and getting no luck!!

 

Could someone tell me the exact permissions i need for the following dir's?

 

- catalog

- catalog/install

- catalog/admin

 

sofar i DID get the /catalog permissions to stay at 704 and allows me to enter. Then I'm setting both config files to 777, and as a last resort det the /install dir to 777...still getting:

 

Forbidden

You don't have permission to access /catalog/install/ on this server.

Link to comment
Share on other sites

I'm using WS-FTP and altering the CHMOD when i right-clik.

 

SO if I'm confused about what permissions I've alterd...how do i start over?

 

catalog dir permissions set to...?

install dir permissions set to...?

 

and I'm assuming 777 is ok for my config files...?

 

any known issues with WSFTP?

Link to comment
Share on other sites

You are not authorized to view this page

You might not have permission to view this directory or page using the credentials you supplied.

 

 

I'm havin an annurism here! somebody help me iron out my permission settings!

Link to comment
Share on other sites

I made CHMOD for the entire catalog folder 777 and i still get:

 

"You are not authorized to view this page

You might not have permission to view this directory or page using the credentials you supplied.

"

Link to comment
Share on other sites

ok..i deleted the catalog folder, and re-uploaded it this time with all PHP xtensions as "PHP" intead of "PHP4"

 

Now..depending on which permissions im playing with i get the old

-404 or 403

OR the following text, which i assume is the install file contents..:

 

<?php

/*

$Id: index.php,v 1.1 2002/01/02 13:02:38 hpdl Exp $

 

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

Copyright © 2002 osCommerce

 

Released under the GNU General Public License

*/

 

require('includes/application.php');

 

$page_file = 'index.php';

$page_title = 'Welcome';

$page_contents = 'index.php';

 

require('templates/main_page.php');

?>

 

I'm getting there...no thanks to you guys!:)

 

How bout a little help here? thought this was a supportive community:)

Link to comment
Share on other sites

644 should be fine for the files with the exception of configure.php files which should be 706 or 777 to install. I think that all of the directories need to be 777 but not positive on that one.

 

If you are seeing:

<?php

/*

$Id: index.php,v 1.1 2002/01/02 13:02:38 hpdl Exp $

 

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

Copyright © 2002 osCommerce

 

Released under the GNU General Public License

*/

 

require('includes/application.php');

 

$page_file = 'index.php';

$page_title = 'Welcome';

$page_contents = 'index.php';

 

require('templates/main_page.php');

?>

it would seem that your php is not being parsed.

 

I know I haven't been much help but maybe I have been.

Who knows?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...