Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Sign in to follow this  
Farrukh

[Contribution] Header Tags Controller for Admin MS 2.2

Recommended Posts

Compare the header_tags_controller.php file located in the admin/includes/languages/english/ directory of the contribution with the same file in the directory of the language you are using. You are missing some definitions that were added to the new version and it seems I forgot to add them to those language files.

 

Jack


Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

Get the latest versions of my addons

Recommended SEO Addons

Share this post


Link to post
Share on other sites

Hello

 

Ive installed header tags V 2.6.2 and my site has disappeared, :'( I get this on the home page:

 

Warning: require(includes/functions/header_tags.php) [function.require]: failed to open stream: No such file or directory in /home/wwwshop/public_html/includes/application_top.php on line 522

 

Fatal error: require() [function.require]: Failed opening required 'includes/functions/header_tags.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/wwwshop/public_html/includes/application_top.php on line 522

 

In my Admin if I click on the heading Header Tags I get this:

 

Fatal error: Call to undefined function GetPermissions() in /home/wwwshop/public_html/admin/header_tags_controller.php on line 22

 

If I click on Page Controller I get this:

 

Fatal error: Call to undefined function GetPermissions() in /home/wwwshop/public_html/admin/header_tags_controller.php on line 22

 

If I click on Text Control I get this:

 

Fatal error: Call to undefined function GetPermissions() in /home/wwwshop/public_html/admin/header_tags_english.php on line 17

 

Header Tags - Fill Tags is the only one that shows up :blink:

 

What have I done wrong?

Share this post


Link to post
Share on other sites

Got my site back but still having problems with Admin

 

Header Tags:

 

Fatal error: Call to undefined function GetPermissions() in /home/wwwshop/public_html/admin/header_tags_controller.php on line 22

 

 

Page Control:

 

Fatal error: Call to undefined function GetPermissions() in /home/wwwshop/public_html/admin/header_tags_controller.php on line 22

 

Text Control:

 

Fatal error: Call to undefined function GetPermissions() in /home/wwwshop/public_html/admin/header_tags_english.php on line 17

 

Help would be appreciated

 

Thanks

 

Fill Tags: Shows up

Share this post


Link to post
Share on other sites

It sounds like you forgot to upload the included files for the first problem. For the second, see the instructions regarding setting the permissions.

 

Jack


Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

Get the latest versions of my addons

Recommended SEO Addons

Share this post


Link to post
Share on other sites

I did upload them, I double checked this before posting. I uploaded the ones from the catalog file I didnt upload anything from the "new shop only" as my store is modified as for the permissions I already set them to 755. I did this before posting. And now my dynamic site map says this:

 

Error!

 

Unable to determine the page link!

Share this post


Link to post
Share on other sites

Sorry Jack, you were right,

 

Stupid me, I double checked, double checked, I uploaded alright. Back to front. Its all there now except the Page Control.

 

I get this at the top of the page

 

Permissions settings for the /home/wwwshop/public_html/includes/header_tags.php file appear to be incorrect

 

I set it to 777, 755 & 644 I kept getting the same error, what silly thing have I done wrong here?

Share this post


Link to post
Share on other sites

Changed it but still get that little red error doesnt seem to want to go away.

 

Permissions settings for the /home/wwwshop/public_html/includes/header_tags.php file appear to be incorrect

Share this post


Link to post
Share on other sites

wwwshop is my catalog, (My last host named it that way, I have since found a new one) the path for backup is

home/wwwshop/public_html/admin/backups

 

I dont have tools. Just admin/backup

 

Header Tags/Page control is there and working, I just get the little red warning at the top.

Im just guessing as I really havent a clue as to why but since installing Header Tags I get an error in my dynamic site map stating Unable to determine the page link!

I also have information pages unlimited update for dynamic sitemap as well, would this have anything to do with it? Any ideas how to get my information pages listed back on my site map as well?

 

I dont think Ive helped you much.

Share this post


Link to post
Share on other sites

Try making a change in Header Tags->Text Control and click on Update. Then look at the english/header_tags.php file to see if the changes were recorded. If they were, then ignore the warning.

 

Jack


Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

Get the latest versions of my addons

Recommended SEO Addons

Share this post


Link to post
Share on other sites

No worries, its all working and being recorded, thanks :)

 

Any ideas on whats happened with my sitemap? Should I jump over to the dynamic support thread for that one.

 

Thanks

Share this post


Link to post
Share on other sites

I'm glad it is working for you. It is usually a good idea to post what fixed it since others may have, or will have, the same problem. As for all products, yes, threads, especially long ones like this one, get confusing if they veer off topic so the question should be asked in its support thread.

 

Jack


Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

Get the latest versions of my addons

Recommended SEO Addons

Share this post


Link to post
Share on other sites

No worries, I was just reading the "How to Operate" and it says this:

 

Go to admin->catalog, click on a category and then on edit. At the bottom of the edit section to the right, you will see a large box for Categories Description.

 

I dont have this. It only appears in my Manufacturers

 

Do you know why (I probably forgot something)

Share this post


Link to post
Share on other sites

It's part of the code so it should be there. Either a mistake was made in the installation or you have a contribution like Categories Description installed, which overrides it. Try replacing your categories file with the one from the contribution. If that option appears, then it is due to a mistake in the installation.

 

Jack


Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

Get the latest versions of my addons

Recommended SEO Addons

Share this post


Link to post
Share on other sites

I have no Categories Description installed, what it is, Is there is no categories file in the catalog file (which is the one I installed due to my site being modified)

There is only a category file in the "catalog_for_new_shop_only" should I install that one?

I didnt do it cause it said "new shop only" this is where I start to get confused when installing mods.

Share this post


Link to post
Share on other sites

Categories Description is a separate contribution. If you don't have it installed, don't work about it. You don't need it with Header Tags installed.

 

You are correct that the categories.php file in the contribution package will not work properly in your shop if you have made code changes to it. But you can use it for testing to see if Header Tags works. So make a backup of your file, upload the included one and see if the problem goes away. If it does, then you have to compare the two files to see where the mistake is at.

 

Jack


Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

Get the latest versions of my addons

Recommended SEO Addons

Share this post


Link to post
Share on other sites

Hi

 

just installed version 2.5.9.1 and all is OK apart from when picking on a category. In the title bar it shows category - store name or manufacturer (genre in my case) - store name ie Artists A-F - ICR records

 

Is it possible to change it to

 

ICR records - category - Artists A-F or

ICR records - genre - breakbeat

 

Thanks

 

Ian

Share this post


Link to post
Share on other sites

I can't follow your example but I think what you want to do would have to be done by changing the code.

 

By the way, why did you choose to install an old version?

 

Jack


Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

Get the latest versions of my addons

Recommended SEO Addons

Share this post


Link to post
Share on other sites
I can't follow your example but I think what you want to do would have to be done by changing the code.

 

By the way, why did you choose to install an old version?

 

Jack

 

Hi Jack

 

thanks for the quick reply. I thought I had to change the code but I'm not sure where. Another way to explain it is to use the reply to this forum. On my title bar I have

 

osCommerce Community Support Forums -> Replying in [contribution] Header tags etc. which is correct. What I am seeing in my site with header tags is

 

Replying in [contribution] Header tags ->osCommerce Community Support Forums as in it's back to front. I thinks that's a bit less muddy.

 

I downloaded it back in June 06 and have just got round to installing it. It wasn't until I got this 'error' that I found out there is a new version.

 

Ian

Share this post


Link to post
Share on other sites

Hi Jack,

 

I've just finished installing Header Tags 2.6.2 but category and manufacturer names are empty.

 

Is it normal or is it done by error(s) in index.php or categories.php? Is it an bug already appeared?

 

Thank's a lot. ;)


Osc v2.3.4 BS "custom"
PHP 7.3 compatible (710 modified files => o_O')

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×