Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Older Braintree versus newer and how to download


timrbetts

Recommended Posts

So we are running an old but highly modified osC v2.2 RC2a and PHP 5.3.3.

We current accept cc and paypal, but want to support Braintree. 

As luck would have it, we found an older 2.3.4 version that only requires PHP > 5.2.1. I was able to install this module and it says version 1.1, but I've no idea if it is stable enough to use or will even work with Braintree. The signature in the module says "braintree|braintree_cc|1.1|2.3" if that helps to identify what this is. 

Given that this version fits nicely with our version of PHP 5.3.3, should I be able to use it or should I download the v4 version and attempt to backport instead? This is a complex module and has lots of underlying classes and so I really don't know if I can trust it. Any thoughts by older Braintree/osC/PHP devs out there?

Assuming I go the backport route, if I go to the app shop on the new site > Payments > online > Braintree, but even after logging into our account, I cannot see any link to add it to my cart or otherwise download the module. Can anyone point me at the actual download or distribution? 

Thanks for the help!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...