Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

error after installation of PayPal V2 for osc 2.x


Fireflash

Recommended Posts

Hello everyone,
I use the old "Responsive-osCommerce-2.3.4-GOLD" newly installed. The automatic installer script worked perfectly.

All files are original !!!
Unfortunately I get the following error message with php 5.6.40.

Warning: The use statement with non-compound name 'PayPal' has no effect in /usr/www/users/ ... /includes/modules/payment/paypal_rest.php on line 16

Parse error: syntax error, unexpected '?' in /usr/www/users/ ... /includes/modules/payment/paypal_rest.php on line 643

Can someone please help me how to fix the error.

Link to comment
Share on other sites

  • 2 months later...

I'm having the same problem right now.

PayPal 2.0 was written for php 7, and like you I'm still running osC 2.3.4 BS GOLD on php 5.6.4, so it doesn't work. This is what the error about the ? is about.

I've put in some work to try and convert PayPal 2.0 to php 5.6.4 but there are a lot of files and I'm no good at php... I may have to ditch PayPal because of this.

Have you found a solution?

Link to comment
Share on other sites

Someone from the oscommerce team might correct me but, as I understand it, the Paypal module they released is not compatible with your version of oscommerce. It could be altered to work with it but will not work as it is.

Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

All of My Addons

Get the latest versions of my addons

Recommended SEO Addons

Link to comment
Share on other sites

No, it is not compatible due to the file structure. It is meant to be ran on oscommerce 2.3 and there is quite a bit of difference between 2.3 and 2.3.4 Gold.

Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

All of My Addons

Get the latest versions of my addons

Recommended SEO Addons

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...