Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Uploaded Images Do Not Appear


CrimSon_ReD

Recommended Posts

Ok imahes I have uploaded into the catagories and for products are coming up with a big x - no image appears.

 

When I right click on the image to check it out, it states that

the image is now located in the catalog/images folder.

 

But now when I peep in that folder through my ftp,

Such uploaded images are not in there...

 

Is this a bug?

and is there a solution to it?

 

Or did I screw something up along the way?

 

Sorry im new to this, but I have to commend you,

This is one heck of a excellent php script. :)

Link to comment
Share on other sites

I think you either looked into a wrong folder or the file is not loaded in there yet.

Another problem I have had with my site was the image was there but the X still appeared. If your FTP sotfware allow user access level, set it to allow all people viewable.

Link to comment
Share on other sites

I think you either looked into a wrong folder or the file is not loaded in there yet.

Another problem I have had with my site was the image was there but the X still appeared. If your FTP sotfware allow user access level, set it to allow all people viewable.

Link to comment
Share on other sites

If the image is not in the /images folder, my first guess would be that file upload is turned off in the php.ini file. It should say

file_uploads = On

upload_tmp_dir = /tmp 

upload_max_filesize = 2M

If file_uploads is not on, it won't work. If your image is larger than the upload_max_filesize, it won't work. If upload_tmp_dir (or the system default if it is commented out) is set to something to which the web server can't write, it won't work.

 

You may not have access to the php.ini file (if you are on a shared server). I think that it is possible to configure this on a per site basis with <Directory> in the httpd.conf (which your host would have to modify) or with .htaccess files (which your host would have to have enabled in the httpd.conf).

 

Hth,

Matt

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...