Jump to content
  • Checkout
  • Login
  • Get in touch


The e-commerce.

No access to admin folder


Recommended Posts


I make a mistake and did not know what. I remove a program. Maybe it was "apt-get remove gnupg". during the process there was some files to auto-delete. I say Yes and did not know what files now.

After it (as I think so) all hosted domains did not work anymore. Only blank pages. I run it on a Plesk-system (no web-login possible after remarking the problem). So I run some reinstall routines from Plesk and after it all works fine. Only not the shop system osCommerce 2.2-MS2. It shows the shop well but I can not access to any admin page. I reinstall a backup of the server config but it did not help. A html file in the admin folder will be shown by the browser (tried more than one). Only the PHP files not. In the log file is only one entry each try:


500GET /admin/orders.php?language=de HTTP/1.0

I try some things with .htaccess but it did not help.

Now I am desperated and hop you can help me.

Thank you.

Link to comment
Share on other sites

@ffffThe error you are getting is a catch-all type of failure that just something went wrong. It is pointing to a language file and since the pages in admin are while, that indicates a problem with those files. It might be that files in the admin were deleted. It doesn't sound like you restored any shop files, though I may not understand all you did. But if you haven't, I suggest restoring the files in your admin, assuming you have a backup of it. I wouldn't restore the shop files since that is working and there's no reason to risk causing problems with it.

You might also want to see if there is a file named error_log in the admin directory. If there is, delete it. Then try loading the admin again and check again for that file (you may need to refresh your viewer). If the file exists, past its contents here so someone can comment on the entries.

Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

Get the latest versions of my addons

Recommended SEO Addons

Link to comment
Share on other sites


OK, my english is not the best. And maybe I say it with the wrong words: No files from the domains was deleted. Only files with the uninstall progress oft gpg (? I think it was the time the problems begin)

All files of oscommerce are there. The orders.php?language=de  was just an example (because it's my bookmark). All other files in admin did not work but still there and with the old file permissions. I did not change anything.

I did not find an error-log. Only system logs and there was only the useless " 500 GET /admin/orders.php?language=de HTTP/1.0 " error

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...