Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

SSL Issue - Broken Padlock sometimes


aspire321

Recommended Posts

I renewed my SSL certificate two weeks ago.

Sometimes I get a broken-padlock warning/error message (loads old certificate for some reason).

I even added this in the htaccess file (to redirect to https site)

RewriteEngine On
RewriteCond %{HTTPS} off
RewriteCond %{HTTP_HOST} ^(www\.)?MYDOMAIN\.com$ [NC]
RewriteRule ^(.*)$ https://www.MYDOMAIN.com/$1 [L,R=301]

 

I tried different settings in the configure files, but that didn't solve it. Currently I'm using this -

<?php

  define('HTTP_SERVER', 'https://www.MYDOMAIN.com');

  define('HTTPS_SERVER', 'https://www.MYDOMAIN.com');

  define('ENABLE_SSL', true);

  define('HTTP_COOKIE_DOMAIN', '');

  define('HTTPS_COOKIE_DOMAIN', '');

  define('HTTP_COOKIE_PATH', '');

  define('HTTPS_COOKIE_PATH', '');

  define('DIR_WS_HTTP_CATALOG', '/');

  define('DIR_WS_HTTPS_CATALOG', '/');

  define('DIR_WS_IMAGES', 'images/');

  define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

  define('DIR_WS_INCLUDES', 'includes/');

  define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

  define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

  define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

  define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

  define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');

  define('DIR_FS_CATALOG', '/home/content/15/3770715/html/');

  define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');

  define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

 

 

And admin uses this -

 

<?php
  define('HTTP_SERVER', 'https://www.MYDOMAIN.com');
  define('HTTPS_SERVER', 'https://www.MYDOMAIN.com');
  define('ENABLE_SSL', true);
  define('HTTP_COOKIE_DOMAIN', '');
  define('HTTPS_COOKIE_DOMAIN', '');
  define('HTTP_COOKIE_PATH', '/Trees');
  define('HTTPS_COOKIE_PATH', '/Trees');
  define('HTTP_CATALOG_SERVER', 'https://www.MYDOMAIN.com');
  define('HTTPS_CATALOG_SERVER', 'https://www.MYDOMAIN.com');
  define('ENABLE_SSL_CATALOG', 'true');
  define('DIR_FS_DOCUMENT_ROOT', '/home/content/15/3770715/html/');
  define('DIR_WS_ADMIN', '/Trees/');
  define('DIR_WS_HTTPS_ADMIN', '/Trees/');
  define('DIR_FS_ADMIN', '/home/content/15/3770715/html/Trees/');
  define('DIR_WS_CATALOG', '/');
  define('DIR_WS_HTTPS_CATALOG', '/');
  define('DIR_FS_CATALOG', '/home/content/15/3770715/html/');
  define('DIR_WS_IMAGES', 'images/');
  define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
  define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . '/images/');
  define('DIR_WS_INCLUDES', 'includes/');
  define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
  define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
  define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
  define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
  define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');
  define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');
  define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');
  define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');
  define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');
  define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');
  define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');
  define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

Do you have any suggestions please, like I've said I already tried many things.

 

PS : I tried adding Strict-Transport-Security to the htaccess but that causes the site to fail to load.

 

Link to comment
Share on other sites

Sounds like a problem your host or service provider should be attending to. If your SSL was working before you renewed it, then you don't need to make changes to these files. 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...