Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Mixed Customers


rfcalloway

Recommended Posts

I was talking to a client of mine today who has a OSC store and he was telling me about an intermittent problem he's been having and I wanted to see if anyone else has run into the issue:

 

A customer submits an order to the store and makes payment & the deliver address is the same as the car address upon entry.

On two occasions when the order is finalized in the db, another customer's info is put into the ship to line item. This makes it look as if a customer in Calif is ordering something for a different person in Texas (for instance). Luckily he caught the issue both times it has happened and was able to get the merchandise to the right person.

 

I have noticed that within a day or so of both events that there were some sever issues at his host. The first time it was a SQL issue and the other time, the server went offline for a few hours. My thoughts are that it is related to those outages but wanted to run the situation by anyone who might have seen the same thing.Thanks! :D

Link to comment
Share on other sites

Just found out that during the latest mix up, there were two customers online order the same item in different quantities. One was ordering 10 of an item and the other was ordering 4... The cust ordering 4 had 10 show up in her basket several times before the nuber 4 properly inserted.

 

:roll:

Link to comment
Share on other sites

Seeing a similar issue here. Details of a different customer are being displayed to the one ordering online. I see several forum posts of a similar nature, and one suggesting that sessions and/or cookies are to blame. Has anyone found a definitive solution?

Link to comment
Share on other sites

I haven't had that problem yet, but my customers addresses are not showing up on any pages.... customer orders, invoices, packing slip or the email that gets sent out.

 

Still haven't been able to figure that one out. Has caused a bunch of problems when it comes time to charge for shipping as the addresses are not being pulled from the database so it can't calculate the shipping the way I need it to, yet the addresses are in the database.

 

Good luck!

Link to comment
Share on other sites

The thing that makes me wonder is that so many similar issues occurred at once, something external to osc must have changed (like a linux upgrade, or cpanel for example) for it to affect so many people at once.

 

I know that cpanel just did a major upgrade. php and mysql also within the last few months. Is there a common thread with people having the problem?

Link to comment
Share on other sites

I doubt that is my problem. Not sure about thiers. I have several sites all hosted on the same server. Some work fine, the one other is having problem after problem after problem.

 

Two different versions of oscommerce though. I am thinking of taking all the pages from one of the sites that work fine, along with the database and just adjust it to make it work for the site that is having all the problems(the one with the newest snapshot the olders snapshots work fine for me). Not sure what else I can do.

Link to comment
Share on other sites

Does the customer allow sessions? ie. How old is the osCommerce version they're running?

 

By the sounds of things, it's pointing towards two clients that were sharing a session.

 

Cheers,

Tony

"The price of success is perseverance. The price of failure comes much cheaper."

Link to comment
Share on other sites

  • 3 weeks later...

I've encountered this problem a bunch of times now.

 

There must be two clients sharing one session.

But is there a workaround?

 

This is a horrible security problem as customers typing in credit card info could show this off to anyone sharing their session.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...