Jump to content
  • Checkout
  • Login
  • Get in touch


The e-commerce.

Change from .htaccess to httpd.conf


Recommended Posts


Have a 2.3.4BS4 Just pre pheonix but with much of it included

Running on apache 2.4.38 PHP 7.2.16 Http/2

I have a large number of diverts and other rules which are growing, the site has been around a long time with a number of website changes

I want to get all the rules in httpd.conf instead, I have done tests and because of the thousands of rules there is improvement on initial page load to make it worth it.

Now my problem is its not load the httpd.conf eve though i delete the top level .htaccess, also tried to delete lower level ones too but to no avail

Now i did not think it was oscommerce but just done a simple test site and it works, so it must be a conflict somewhere with OScommerce, Now i tried to test with a out of the box Phoenix and that works to so its possibly something thats been added at some time, has anyone come up with this before or could think what might be causing the issue currently my test divert 301 is coming back with


Not Found

The requested URL /orange.php was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Now i thought it was going to be one of the other htaccess files but pretty sure i deleted them all.

I even managed to get RewriteOptions InheritBefore on my simple tests, but with a copy of my main site cant get it to see at all.

Any ideas would be welcomed




Link to comment
Share on other sites

@ecartz @ArtcoInc

Thank you or looking, Yes, I can get it working as it should, with, without htacess or appended with, using both a simple site and a fresh install of phoenix, this is using the same web-space as its my test area, bu not the slightly older version that has had a good few things added, like USU5 pro, header status, there must be something conflicting, thats why I thought i would loose all of the htacces files, but come to think of it it will not work if the upper directory Allowoveride is None anyway so a redundant path, I am just going to have to slowly pick it apart to find out which it is


Link to comment
Share on other sites



After many sleepless nights I managed to get it working, with so far one problem, the product page image is not popping to larger image, cant find the issue yet, think it must be path related

The biggest issue was with the seo rewriter URLS5 PRO but manged to change a few of the lines to get it working

My old htaccess had thousands of lines and now its in httpd.conf I have knocked quite a bit off initial load time

Unless you have a lot of diverts like me though I do not think it would be worth it



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...