Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

torinwalker

New UPS XML Shipping Module available

Recommended Posts

thanks john, worked wonderfully. and yes thankfully i just bought hosting from godaddy for 1 month. Probably going to switch to host gator or lunarpages because I have heard nothing but good reviews for them, unlike godaddy, oneandone, etc.


STUFF TO DO:

-change boxes on left side to desired style

-remove default mini pictures (cartoon ones)

-modify some of the text colors

-change text headings ("Whats new here" etc.)

-add shipping modules

-add credit card module that allows to stay on my site

-remove all or all but 3 of the "new products" at bottom of main screen

-change button styles

-add SSL

-add the products from TIGI

Share this post


Link to post
Share on other sites
The Canada Post 3.1 module I had installed adds an extra 3 kg to the shipping cost for no apparent reason. Just the way the guy laid out his variables. I've fixed it in mine (since I derived code from his), but now I've got to go and fix his module as well. Good lord...

 

I've got the same problem. Do you recall the fix offhand?

Share this post


Link to post
Share on other sites
I've got the same problem. Do you recall the fix offhand?
A typical case of RTFM :) , code word is Package Tare Weight. Edited by JanZ

Share this post


Link to post
Share on other sites

I have a contract with UPS for lower air rates. Could someone tell me how to modify this program for air services. I tried the negotiated rates change but it did not work.

 

I would like to multiply all rates (other than Ground and 3 Day Select) by a percentage and return the lower rate.

 

Any help would be very much appreciated.

 

Thanks,

 

Donna

Share this post


Link to post
Share on other sites
I tried the negotiated rates change but it did not work.
I wonder if that is because the instructions in the forum where not adequate or because UPS is not returning your negotiated rates?

 

I do have a new version that includes the negotiated rates and a few more changes (a fix for the insurance e.g.) but I never heard anything back from my beta tester so never added it to the contribution page.

Share this post


Link to post
Share on other sites
Guest
thanks john, worked wonderfully. and yes thankfully i just bought hosting from godaddy for 1 month. Probably going to switch to host gator or lunarpages because I have heard nothing but good reviews for them, unlike godaddy, oneandone, etc.

This is an interesting topic. Web hosting; I have been through quite a few companies before I learned that the main issue was being on a shared server. You never know when, you can count on it happening at some point, someone will get an account on the same server your account is on and start tying up the server resources with some sort of spam script. I finally couldn't take it anymore and now have dedicated servers. I'm very careful about who I let on it.

 

As for the price of dedicated servers, I recommend hostgator. The amount of server software you get with them is unbeatable, however, and this is a BIG HOWEVER, be prepared for one of he worst support systems I have ever seen.

Sorry for going a bit off-topic. Seeing as we all need web space hosted somewhere.... :-"

Edited by HallMarc

Share this post


Link to post
Share on other sites

Hi there, I installed the ups xml contribution and am getting the following error message after the install on attempting to edit the module in the admin. Any clues? Sorry I am quite the php newbie.... any help would be greatly appreciated.

 

Parse error: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING, expecting ')' in /data/11/0/125/46/940698/user/966995/htdocs/catalog/admin/modules.php(202) : eval()'d code on line 1

Share this post


Link to post
Share on other sites

HallMarc, don't be sorry for this because look how many people have had issues that hosting related.

 

Hosting for an e-commerce site is as important as air quality and it seems way too many people overlook it. I've got a great webhost (AAbox) and while not the least expensive they are very dependable and I've always received great service from them. Plus, they know OSC well.

 

Anyway, Mike told me the only negative to a dedicated server is the price and one day I might make that leap, but I need the support so I'll probably do it with them. It seems just having the MySql dedicated is worth it.

 

The way I look at this is I want to remove anything within reason that will impede sales, plus I need sales to grow at least 20% a year going forward.

Edited by John Wisdom

John Wisdom

Share this post


Link to post
Share on other sites

I have installed the module following the instructions perfectly. I have all the settings inputted, I have signed up for UPS, got the access key, the works. Everything in the admin panel seems normal, it's turned on, but for some reason, it never shows up when placing an order. It doesn't offer any shipping options at all. The UPS XML Module is the only one active, but it will just let you place an order without doing any shipping at all. Any ideas? I DO have curl compiled and started with PHP.

Share this post


Link to post
Share on other sites
It doesn't offer any shipping options at all
Are you sure you have not enabled UPSXML only for a certain shipping zone? If the client is not from this shipping zone it will not show up.

Share this post


Link to post
Share on other sites
Are you sure you have not enabled UPSXML only for a certain shipping zone? If the client is not from this shipping zone it will not show up.

Thank you... don't I feel foolish now.... :blush:

Share this post


Link to post
Share on other sites

I'm having an odd problem with my newly installed UPS XML shipping module.

 

It installed fine, but when I try to put in the details to configure it none of them are saved. It *looks* like it edited the module successfully, but none of the details that I put in are listed and the module doesn't work.

 

Anyone have any ideas? I followed the instructions to the letter (I thought). Can anyone let me know where the UPDATE string for this would be, so I can see if there are any mySQL errors being thrown?

 

Thanks.

Share this post


Link to post
Share on other sites
I'm having an odd problem with my newly installed UPS XML shipping module.

 

It installed fine, but when I try to put in the details to configure it none of them are saved. It *looks* like it edited the module successfully, but none of the details that I put in are listed and the module doesn't work.

Has nothing to do with UPSXML and everything with a bug apparently not experienced by everyone in admin/modules.php after the August 17, 2006 update (something to do with the compatability thingy something I believe).

 

I think the solution is to change line 46 of the following 43-46:

  if (tep_not_null($action)) {
switch ($action) {
  case 'save':
	while (list($key, $value) = each($HTTP_POST_VARS['configuration'])) {

to:

		foreach($_POST['configuration'])) {

Share this post


Link to post
Share on other sites

Is this module also capable to calculate the volume/weight ratio and irregular-formed-package-fee for shipments longer as 150cm?

 

For parcels longer as 150 cm. UPS will base the shipping weight on their calculated volume/weight ratio = length x width x high (in cm) / 6000

All these measurements are available in the database.

 

HanZ


Grtz

 

HanZ

 

 

 

-----------

Life is simple, only people make it complicated...

Louis Couperus, Dutch writer (1863-1923)

Share this post


Link to post
Share on other sites
Is this module also capable to calculate the volume/weight ratio and irregular-formed-package-fee for shipments longer as 150cm?

 

For parcels longer as 150 cm. UPS will base the shipping weight on their calculated volume/weight ratio = length x width x high (in cm) / 6000

All these measurements are available in the database.

Actually, I recall having read that all shipments of UPS will use that for the billing. Anyway, if you already have all measurements of your products (including the volume needed for packaging material..) in the database, you can add the measurements of your boxes and go the full dimensions way. Those items are a problem though, because you don't want to have such long boxes available for the packaging routine (they will be used in the end).

 

The simplest option would be to declare such a product "ready-to-ship". The packaging routine will use the dimensions and UPS will recognize that it is irregularly formed (OS1 or OS2 I think their terminology is). No need to declare that in the XML. When you can and put two of these products in one box.... that is a problem because at the moment there is no way to restrict certain products to certain boxes.

Share this post


Link to post
Share on other sites
Has nothing to do with UPSXML and everything with a bug apparently not experienced by everyone in admin/modules.php after the August 17, 2006 update (something to do with the compatability thingy something I believe).

 

I think the solution is to change line 46 of the following 43-46:

  if (tep_not_null($action)) {
switch ($action) {
  case 'save':
	while (list($key, $value) = each($HTTP_POST_VARS['configuration'])) {

to:

		foreach($_POST['configuration'])) {

 

 

Doing that disables my entire shipping modules section. When I click on "shipping" under "modules" I just get a blank screen.

 

Also, while this may not have anything to do with the UPSXML module, all of the other modules are functioning fine, including being able to edit them.

Edited by Helter

Share this post


Link to post
Share on other sites
Doing that disables my entire shipping modules section. When I click on "shipping" under "modules" I just get a blank screen.

 

Also, while this may not have anything to do with the UPSXML module, all of the other modules are functioning fine, including being able to edit them.

 

 

OK, this is really weird. when I click on "update" it takes me to "https://hhiwh.com/rxcart/admin/modules.php?set=shipping&module=upsxml"

notice the lack of an "action=save" at the end of that? That's not the url that the form is supposed to go to, that's the url that the cancel button it linked to. I converted the form method to "GET" rather than post to see if maybe it was just not sending any of the form information, but it still was, so it's not that the button is just mislabeled or something silly like that. I also noticed while viewing hte html that the "update" 1) is an image rather than a button and 2) has no name attribute. Is it possible that one of those

 

I tried this in IE, just in case it was Firefox being touchy about it's form fields or something, but no luck.

 

I also just checked, and apparantly *none* of my shipping modules are saving properly, and all of them are being directed to the wrong url in a similar way...

Share this post


Link to post
Share on other sites
OK, this is really weird. when I click on "update" it takes me to "https://hhiwh.com/rxcart/admin/modules.php?set=shipping&module=upsxml"

notice the lack of an "action=save" at the end of that? That's not the url that the form is supposed to go to, that's the url that the cancel button it linked to. I converted the form method to "GET" rather than post to see if maybe it was just not sending any of the form information, but it still was, so it's not that the button is just mislabeled or something silly like that. I also noticed while viewing hte html that the "update" 1) is an image rather than a button and 2) has no name attribute. Is it possible that one of those

 

I tried this in IE, just in case it was Firefox being touchy about it's form fields or something, but no luck.

 

I also just checked, and apparantly *none* of my shipping modules are saving properly, and all of them are being directed to the wrong url in a similar way...

 

nevermind, it's just a redirect at the end of the "save" case.

 

I'm baffled as to why changing the nature of this "while" loop in the save case completely disables my shipping module, even when the action value is not set to save...

Share this post


Link to post
Share on other sites
Doing that disables my entire shipping modules section. When I click on "shipping" under "modules" I just get a blank screen.

 

Also, while this may not have anything to do with the UPSXML module, all of the other modules are functioning fine, including being able to edit them.

You are right, it should be:

foreach($_POST['configuration'] as $key => $value) {

By the way, you should not leave your admin folder named admin. Call it whatever you like (not newadmin or _admin or something simple). Change your configure.php's accordingly :)

Edited by JanZ

Share this post


Link to post
Share on other sites

SUCCESS!

 

The solution was basically as posted, but was missing a crucial piece (which I realized after looking up how the "foreach" statement could be used similarly to what was originally there).

 

foreach($HTTP_POST_VARS['configuration'] as $key => $value){

 

Is placed in place of

 

while (list($key, $value) = each($HTTP_POST_VARS['configuration'])) {

 

Thank you very much for your help! Hopefully this will help someone else out in the future.

Share this post


Link to post
Share on other sites

I just finished installing UPS XML Rates v1.2.4 along with Dimensional Support. These are really great contributions. The installation went fine for both. Does anyone know if there is any user documentation for these contributions? What is the difference between entering the length-width-height directly from the Categories / Products page for each item verses the packaging table in Admin ->Tools -> Packaging? Where does Ready to Ship come into play? Maybe I missed it in the install doc’s or I’m just burnt out after doing the installation. Any help would be greatly appreciated!!!

Share this post


Link to post
Share on other sites
Does anyone know if there is any user documentation for these contributions?
Not more than what is mentioned in the various files in the package.
What is the difference between entering the length-width-height directly from the Categories / Products page for each item verses the packaging table in Admin ->Tools -> Packaging?
In tools->packaging you enter the dimensions of the boxes you use for shipping.
Where does Ready to Ship come into play?
When an item is shipped in its own box (for example an appliance) and so doesn't need to go through "packaging". In standard osC the total weight of all items is taken, a formula for tare is applied and then it is divided by the maximum weight per box, rounded up to get to the number of boxes. With the ready-to-ship option for dimensions support, items shipped in their own box will be excluded from that formula. For some people that is handy.

Share this post


Link to post
Share on other sites
Not more than what is mentioned in the various files in the package.

In tools->packaging you enter the dimensions of the boxes you use for shipping.

When an item is shipped in its own box (for example an appliance) and so doesn't need to go through "packaging". In standard osC the total weight of all items is taken, a formula for tare is applied and then it is divided by the maximum weight per box, rounded up to get to the number of boxes. With the ready-to-ship option for dimensions support, items shipped in their own box will be excluded from that formula. For some people that is handy.

 

Thank you for the quick response!!! Great contribution.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×