Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Archived

This topic is now archived and is closed to further replies.

Guest

Just a quick PayPal question, please?

Recommended Posts

Guest

I've been here for maybe 5 minutes.  I've had OSCommerce uploaded for maybe 10, ha.  I just want to ask this, while I'm kicking the tires, before I freak out and start editing things. 

PayPal...  will I get a "Things don't seem to be working"  (while I'm testing it) simply because I'm trying to purchase from myself?  I have the API ID in place, all of that and I'm getting ready to roll up my sleeves and get greasy with it, but could it be as simple as that; that it won't complete because I'm trying to buy with my PP account (which is also the seller account)?

Be nice, I'm new and sensitive.  😊

Share this post


Link to post
Share on other sites

You are correct. You can't use your own paypal account to plance an order. Paypal won't allow that. If you have a friend or family member with a paypal account you could have them test it. Or you can create a second paypal account and use it to pay.

But the message you are getting is most likely not due to that, though it can be. It can be caused by a number of things, usually related to the Express module so I suggest you do the following:

- First, and most important, make sure you are using the Frozen version of oscommerce found here..

- Second, install and setup the Paypal Standard module. It may not be the one you end up using but it is the easiest to get to work. Be sure to enter the PDT string in its settings.

Then test the module and see if there are any problems. If not, and if you want to use one of the other paypal methods, enable the one you want and test it. If it doesn't work, post back here with what you did and how it is failing.


Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

Get the latest versions of my addons

Recommended SEO Addons

Share this post


Link to post
Share on other sites
Guest

Hi, Jack and thanks so much for the reply.  I'm relieved to say that it turns out that my version of osCommerce is 2.3.4.1.  (I had been searching online for a responsive shopping cart and followed my leads to this site.)  I've never attempted having a shopping cart before, so I'm doing all this on a testing domain until I'm less afraid of breaking something.  I do have the PayPal Standard module installed and configured (although I'll go back and recheck those settings).  I haven't tested it in Sandbox mode yet, I suppose I could try that.  You know, I've always been under the impression that PayPal didn't allow multiple accounts, so I never considered opening a second one.  I'm not sure why I believed this.  😊

Thanks again, and I'll let you know how it goes. 

 

Share this post


Link to post
Share on other sites
Quote

my version of osCommerce is 2.3.4.1

I'm going to give you 100:1 odds that what you have is the "official" osC 2.3.4.1 downloaded from this site. The bad news is that version is totally obsolete and you will have nothing but trouble with it if you try to set up a "real" store (as opposed to just playing around with it). You need to use "Frozen" (see the link below in my signature), which is PHP 7.1 ready, mobile-friendly, and is much more up to date with more features. At some point you will need to completely remove the official 2.3.4.1 and install the Frozen version. Sorry.

Share this post


Link to post
Share on other sites
Guest
1 hour ago, MrPhil said:

I'm going to give you 100:1 odds that what you have is the "official" osC 2.3.4.1 downloaded from this site. The bad news is that version is totally obsolete and you will have nothing but trouble with it if you try to set up a "real" store (as opposed to just playing around with it). You need to use "Frozen" (see the link below in my signature), which is PHP 7.1 ready, mobile-friendly, and is much more up to date with more features. At some point you will need to completely remove the official 2.3.4.1 and install the Frozen version. Sorry.

Actually, this is the best possible time to start all over with the Frozen version.  My server is already set to PHP 7.1 and since I'm doing all this on an test site, now is my window of opportunity.

I did manage a successful PayPal transaction (wow! they kept 33 cents of a one-dollar purchase).  But already, I can see what you mean about the version I'm using being buggy.  For one thing, there is no logout option after purchase (at least I can't spot it).  And I see no login option for a customer to return to his or her account without having to purchase something.  So I need to do what you said and start over.  Thanks for explaining it to me.  😊

Share this post


Link to post
Share on other sites

Glad to have helped before you got in too deeply. Unfortunately, the only guy (the forum and product owner) who can elevate "Frozen" to the official product status has been AWOL for over a year, so we have this continuous problem of innocent victims installing the old, obsolete code and we then have to tell them they should have installed the community-supported version instead! And that version, in turn, is kept updated by only one (other) guy, who could take the ball and go home at any time. At least it's open source (on GitHub) and free, so someone else can take over in that event.

I suspect some of the weird things you were seeing may have been old osC code incompatibility with PHP 7.1, rather than design flaws as such. You may find some squawking in various error logs. Regarding PayPal, they certainly can be expensive! It takes quite a fair volume of sales before it's worth moving to a Merchant Account with Payment Gateway to directly handle credit card purchases (don't forget to factor in PCI-DSS compliance costs). You might also want to look at other Third Party payment systems such as Stripe and Authorize.Net -- they might be cheaper for you than PayPal.

Share this post


Link to post
Share on other sites
12 hours ago, IAmGrammy said:

For one thing, there is no logout option after purchase (at least I can't spot it).  And I see no login option for a customer to return to his or her account without having to purchase something

That might be that you haven't installed some of the modules in admin->Modules, assuming the version you have has them. The Frozen version will.


Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

Get the latest versions of my addons

Recommended SEO Addons

Share this post


Link to post
Share on other sites
Guest
2 hours ago, MrPhil said:

Glad to have helped before you got in too deeply. Unfortunately, the only guy (the forum and product owner) who can elevate "Frozen" to the official product status has been AWOL for over a year, so we have this continuous problem of innocent victims installing the old, obsolete code and we then have to tell them they should have installed the community-supported version instead! And that version, in turn, is kept updated by only one (other) guy, who could take the ball and go home at any time. At least it's open source (on GitHub) and free, so someone else can take over in that event.

 

I guess the only option would be to actually put a little "note" on the download page, or maybe a pop-up that advises the user of this?  Kind of like a little yellow "sticky"!  😃

I'll look into some payment alternatives; good idea, thanks!

Share this post


Link to post
Share on other sites
Guest
1 hour ago, Jack_mcs said:

That might be that you haven't installed some of the modules in admin->Modules, assuming the version you have has them. The Frozen version will.

Would it be anything other than admin---->Modules--->Content Modules----->Login  ?  That's enabled but I'm not seeing it.  (Unless that hyperlink in the customer greeting is what's meant by login?)  I just downloaded and reinstalled the latest Frozen version from github, so I'm still tinkering, ha.  😊

Edit:  I did just create a test account and i was greeted and now find myself being asked if I want to see new products, but there is no other indication that I have an account.  Even my name is not a link to an account.  Weirdness abounds, ha!

Share this post


Link to post
Share on other sites
48 minutes ago, IAmGrammy said:

I guess the only option would be to actually put a little "note" on the download page, or maybe a pop-up that advises the user of this?

As far as I know, the only guy who can do this is missing in action for the last 18 months or so. He won't promote the much-better Frozen to full osC 2.3.5 or 2.4 status, which would be even better than telling people, "Here's the downloadable version. Oh by the way, it's no good -- go here to get a better version!"

Share this post


Link to post
Share on other sites
2 hours ago, IAmGrammy said:

Would it be anything other than admin---->Modules--->Content Modules----->Login

In the frozen version, enable the admin->Modules->Navbar modules->Account module.


Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

Get the latest versions of my addons

Recommended SEO Addons

Share this post


Link to post
Share on other sites
Guest
3 hours ago, MrPhil said:

As far as I know, the only guy who can do this is missing in action for the last 18 months or so. He won't promote the much-better Frozen to full osC 2.3.5 or 2.4 status, which would be even better than telling people, "Here's the downloadable version. Oh by the way, it's no good -- go here to get a better version!"

Well, that's sad...  that's similar to what happened over at SimpleMachines.  But they keep chipping away at it, to their credit. 

Share this post


Link to post
Share on other sites
Guest
1 hour ago, Jack_mcs said:

In the frozen version, enable the admin->Modules->Navbar modules->Account module.

You're a rock star!  😃

Share this post


Link to post
Share on other sites
Guest
31 minutes ago, ArtcoInc said:

Admin -> Modules -> Content Modules -> Account Block -> Footer

Thanks so much, you reminded me that I wanted to sort the footer.  😀

Share this post


Link to post
Share on other sites
Guest

P.S., I think this bug is still in the new release.  I just had to make this edit to get the banner edit feature to appear in Admin.

 

  On 6/4/2018 at 8:23 AM, BrockleyJohn said:

Another bug: admin/includes/classes/phplot.php throws the error unexpected } on line 1322.

Add a curly bracket to the end of line 1320, like this:

		if (is_array($color_asked) && (count($color_asked) == 3)) {
	   		$ret_val =  $color_asked;
		} else { // is asking for a color by string

 

Share this post


Link to post
Share on other sites

@IAmGrammy

1 hour ago, IAmGrammy said:

P.S., I think this bug is still in the new release.  I just had to make this edit to get the banner edit feature to appear in Admin.

Which "new release"? Frozen? Edge?

M

Share this post


Link to post
Share on other sites
Guest
2 hours ago, ArtcoInc said:

@IAmGrammy

Which "new release"? Frozen? Edge?

M

Oh, sorry, we were talking about Frozen earlier and I guess that's what happens when I don't stick to the original topic.  I hijacked my own thread, ha!  I meant the new release of Frozen on the Github link.  😊

Share this post


Link to post
Share on other sites
Guest

I hadn't seen it,  Artcoinc; thanks so much for posting the link here.  I only stumbled on that fix for editing the banner by doing some pretty extensive online searches, which ultimately led me back here.  I'm methodically working my way through things, so I'd better take a breather and read through that thread you started, before I go much further. 

Thanks!

Edit:  That post I quoted was actually quoted by someone else looking for help with editing their banner.  I didn't know which thread it was lifted from until now.  😊

Share this post


Link to post
Share on other sites

×