Jump to content
  • Checkout
  • Login
  • Get in touch


The e-commerce.

PHP version question Compatibility


Recommended Posts

If I remember right the construct is fine, but you will have many other issues migrating from 5.6 to 7+  as 5.6 has been around a loooooooong time! add-ons writen for 5.6 could be as old as osC2.2 so you will find many conflicts just to do with osC code structure.

It's a question of test find issues and fix. More info below.



Link to comment
Share on other sites


Oke, just asking i'm busy with some upgrading of the code of oscommerce.

I was at 4 - 1 - 2015 with my shop little bit old.

Now i'm at 14 - 3 - 2018


Skipped this one :


But that one should be save to do.

Think i'm good for up to 26 - 8 - 2018

Greetings, Dj Viper

Link to comment
Share on other sites


5 hours ago, Dj-Viper said:

1. are addons etc made in 5.6 php still compatible with 7.0

2. Are for example __construct used for php 7.0 also good in PHP 5.6

If you have the final CE shop, it is compatible with, at least, 7.0 and I think any addons that work with the CE version will also work. But there are problems with some of them when an upgrade to php 7.2 is made.

Generally speaking, you don't have to worry about backwards-compatibility. The newer php versions offer commands that are not in earlier versions but none of those are used in the CE or addons. Unless it is some new addon where the developer uses them.

Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

All of My Addons

Get the latest versions of my addons

Recommended SEO Addons

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...