Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

ssl


Guest

Recommended Posts

ssl is secure socket layer and you don't need any folders for it to work

just set the right parameters in

catalog/includes/configure.php

admin/includes/configure.php

if you need more help let me know,

BTW who is your hoost, or are you doing it locally?

The more you do, the more you learn

Link to comment
Share on other sites

I'd be interested in more info. I'm working with my web host (calanhost.com) and they have given me my shared secure url, and I know I have to enable SSL in the configure.php, but what else do I do? Any help really appreciated

Link to comment
Share on other sites

there isn't really anything to do, once you setup your configure.php

that is it, given the path is correct it will work.

if you get stuck let me know :)

The more you do, the more you learn

Link to comment
Share on other sites

where and how do you put the path in? i read another thread and Bear said that you had to put the path in both the /admin/configuration.php file and the /includes/configure.php file.

 

Is that correct? If so can you show me where in the files and what the syntax is?

Link to comment
Share on other sites

Yeas that''s correct you need to do both catalog and admin

the /catalog/includes/configure.php will look something like this

 

  define('HTTP_SERVER', 'http://yourserver.com');

 define('HTTPS_SERVER', 'https://yoursslserver.com');

 define('ENABLE_SSL', true); 

 define('DIR_WS_CATALOG', '/'); 

 define('DIR_WS_IMAGES', 'images/');

 define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

 define('DIR_WS_INCLUDES', 'includes/');

and so on

If you are using your hosts ssl (aka shared ssl)

your path will look somthing like this:

'https://somesrver.com/~yourusername/your instlall path'

 

Now for the admin section it is all the same

file path is /catalog/admin/includes/configure.php

and the code should look like this:

  define('HTTP_SERVER', 'http://yourserver.com');   

 define('HTTP_CATALOG_SERVER', 'http://yourserver.com');

 define('HTTPS_CATALOG_SERVER', 'https://yoursslserver.com');

 define('ENABLE_SSL_CATALOG', 'true');

that should do it, let me know if it works

The more you do, the more you learn

Link to comment
Share on other sites

I enabled SSL in both files and put the path in both files now when I click on "checkout" i get the following error

 

CGI Error

The specified CGI application misbehaved by not returning a complete set of HTTP headers. The headers it did return are:

 

 

 

Can you help me?

Link to comment
Share on other sites

it looks like an internal server error ,at least i think?

osc and cgi don't really have anything in common

but than again you never know

The more you do, the more you learn

Link to comment
Share on other sites

yes i ment the server your host

but any way that is easy to check

here is what you do make a page any kind of blank html will do fine

than put it somwhere on your server and try to access it by typing the address using the information your host gave you for ssl path

Such as:

"https://ssl.hostname.netxtremelyfitcom/xtremelyfitcom/shop/catalog/thefileyoumade.html" you should than be able to see the file in secure mode

if that works than, it's not the server but OSC, but from my expirience the ssl path might be wrong can you PM me the path that the host supplied you with?

shared ssl paths usually are like such:

"https://ssl.hostname.net/~your account username/shop/catalog"

that what it should look like in the configuration.php files

notice no/ slash at the end just ..../shop/catalog not ...shop/catalog/

The more you do, the more you learn

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...