Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Errors Post intstall


Guest

Recommended Posts

I installed OS, and it seems my main page came up fine.

I got a warning saying I needed to delete my install folder and chmod my configure files in catalog and admin, after that, I get an error-

 

Warning: main(includes/languages/.php) [function.main]: failed to create stream: No such file or directory in /opt/at/catalog/includes/application_top.php on line 271

 

Fatal error: Failed opening required 'includes/languages/.php' (include_path='.:/usr/local/lib/php') in /opt/at/catalog/includes/application_top.php on line 271

 

http://www.automotivetech.org/catalog/default.php

 

Seen there

I did change the chmod back and still nothing.

I am able to make changes to my admin settings fine.

 

I am tired and searched a bit but could not find anything on it?

 

Help, please

Link to comment
Share on other sites

Your problem is with languages, not permissions or default.php/index.php.

Check your languages table and make sure that all fields are filled and correct. Check for DEFAULT_LANGUAGE being set to something meaningful (like 'en') in your configuration table.

Regards, Wizzud

"It is better to remain silent and be thought a fool, than to open your mouth and remove all doubt."

Link to comment
Share on other sites

Use the phpMyAdmin (or similar) front end to your database. If you don't have it available I strongly suggest you get it - its invaluable for testing, problem solving, and simple inspection of data.

Download from http://www.phpmyadmin.net

Regards, Wizzud

"It is better to remain silent and be thought a fool, than to open your mouth and remove all doubt."

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...