Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Warning: main(includes/languages/.php) [function.main]:


x-plosiv

Recommended Posts

hi...i have run the install.php....

 

New Install

 

Step 2: osCommerce Configuration

 

The configuration was successful!

 

when i click on the buttons to Catalog or Administration Tool

 

 

Warning: main(includes/languages/.php) [function.main]: failed to create stream: No such file or directory in /home/fanclubstjakob/public_html/catalog/admin/includes/application_top.php on line 190

 

Fatal error: main() [function.main]: Failed opening required 'includes/languages/.php' (include_path='.:/usr/share/pear') in /home/fanclubstjakob/public_html/catalog/admin/includes/application_top.php on line 190

 

 

thanks for your help....i hope you understand me...my english is bad :-)

Link to comment
Share on other sites

I had that problem with an install of the CVS version.

 

You may want to download and install the MS1 version and try it.

Link to comment
Share on other sites

that is the same error i got when i entered in the wrong host name, once corrected it worked great

 

thanks...

 

you know the hostname from the database? that's localhost and that right.

i can connetc my database with localhost.

 

i think is a error in the languages/.php file

 

.php is no file name???

Link to comment
Share on other sites

when i open http://www.fanclubstjakob.ch/catalog/admin/

i coming my error...i can't see this file in the browser

 

Warning: main(includes/languages/.php) [function.main]: failed to create stream: No such file or directory in /home/fanclubstjakob/public_html/catalog/admin/includes/application_top.php on line 190

 

Fatal error: main() [function.main]: Failed opening required 'includes/languages/.php' (include_path='.:/usr/share/pear') in /home/fanclubstjakob/public_html/catalog/admin/includes/application_top.php on line 190

Link to comment
Share on other sites

I have exactly the same problem as you x-plosiv. I cannot get to the GUI admin screen and set the default language...however, i'm guessing here but the following code taken from english.php may have something to do with the problem?;

 

Released under the GNU General Public License

*/

 

// look in your $PATH_LOCALE/locale directory for available locales..

// on RedHat6.0 I used 'en_US'

// on FreeBSD 4.0 I use 'en_US.ISO_8859-1'

// this may not work under win32 environments..

setlocale(LC_TIME, 'en_US.ISO_8859-1');

define('DATE_FORMAT_SHORT', '%m/%d/%Y'); // this is used for strftime()

define('DATE_FORMAT_LONG', '%A %d %B, %Y'); // this is used for strftime()

define('DATE_FORMAT', 'm/d/Y'); // this is used for date()

define('PHP_DATE_TIME_FORMAT', 'm/d/Y H:i:s'); // this is used for date()

define('DATE_TIME_FORMAT', DATE_FORMAT_SHORT . ' %H:%M:%S');

 

_______________________

 

 

It seems to me like the version i have installed (CVS) has an issue with this in a windows environment. My testing environment is windows - & my host is running a windows environment (once i do actually bring OScomm on board).

 

Can anyone out there shed some light on this??

Link to comment
Share on other sites

I havnt actually made any changes to anything but ..for some reason.. i occassionally access the main admin page via the browser (this has happened twice).

 

Once i click on the 'languages' link under localisation, i get the following error:

 

CGI Error

The specified CGI application misbehaved by not returning a complete set of HTTP headers. The headers it did return are: (blank)

Link to comment
Share on other sites

Heres the latest from my end. I downloaded the latest snapshot which is dated 06/23/2003 & reinstalled 'catalog' & 'admin' and started again.

 

I followed the install procedure and got to the end of Step2:Configuration - configuration was successful!

 

When clicking the catalog or admin buttons on this page, i CAN access them..........

 

BUT....when i click ini a couple of levels eg. click configuration - then one of the config options, i get the following error message fromt the browser:

 

The directory name is invalid

 

I am using Dreamweaver MX and had uploaded all files to the testing server.

 

x-plosiv : I think it would be worthwhile for you to try again and do a fresh install of the new snapshot - just in case this last error is something specific to my setup.

 

In the meantime, fresh input would be gratefully received :)

Link to comment
Share on other sites

x-plosiv : well, you wont know if you do or do not get the same error unless you try to re-install yes?

 

please post your results here either way.

 

Thanks.

Link to comment
Share on other sites

x-plosiv: Either no you havnt installed the latest snapshot or you THINK you have...time to take your finger out and get to it bud - cos it works.

 

Ok - At last! I've got there.

 

The new snapshot does fix the problem. Simply download it x-plosiv and install from scratch. My problem was that having done that i was then getting a 'this directory is invalid' error - however, this was an IIS error and the fix is as follows just in case you encounter it:

 

In IIS settings:

 

- go to the default website properties

- 'Home Directory' tab > configuration > Mappings > select .php and Edit

- in the Add/Edit Application Extensions Mapping swithc ON 'Check that file

exists'

 

 

Good Luck!

Link to comment
Share on other sites

Install MS1 - if you read Haralds post in announcements you will find that he recommend snapshots for experienced developers only and that a snapshot WILL break your store.... or, wait for the (DELAYED) release of MS2.... perhaps its delayed because there are problems..??

Link to comment
Share on other sites

Could this be a differance in the operating systems??

I successfully setup oscommerce on a win98 machine with xitami, mysql,& php. administration works perfectly. This was a test machine. The server I am setting up uses win2k, xitami,mysql,php I receive this error message when I access the administration Page

"Warning: main(includes/languages/english/): failed to open stream: No such file or directory in C:Xitamiwebpagescatalogadminincludesapplication_top.php on line 193" Also none of the links on the administration page work. I think it is a pathing problem the machine with win98 is a stand alone machine. The machine with win2000 is on a cat5 router with cable access. I am at a loss :?: Thanks in Advance for any help. Jim

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...